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1.  An Introduction to star writer 
 

1. The thick horizontal line in the area is called____. 

     a) End of the page b) End of the document c) End of the document marker d) None 

2. ____ Key deletes the characters to the right of the insertion point. 

    a) Delete b) Backspace c) Enter d) Shift 

3. The ___ is used to create a database. 

    a) Star writer b) Star draw  c) Star calc d) Star base 

4. ____ key combination is used to move to the end of the document. 

   a) Ctrl + Home b) Ctrl + End  c) Shift + Home d) Shift + end 

5. The word to be used as replacement for the word search is given in the ____ text box. 

   a) Replacement b) Replace with c) Suggestion d) Search for 

6. ___ key is used to select the entire document in star writer. 

   a) Ctrl + A  b) Ctrl + L c) Ctrl + E d) Ctrl + D 

7. The page preview option is available under the ____ menu. 

   a) Format b) Edit  c) File  d) View 

8. The default name for the new document of star writer is ____. 

   a) Untitled  b) Untitled 1  c) No – name d) Default 

9. ___ is not a word processor. a) Note pad     b) Star writer c) MS- word  d) Word star 

10. The term word processing refers to the activity carried out ____. 

   a) To view  b) To create  c) To manipulate d) All the above 

11. ___ is the keyboard shortcut for saving the document.  

  a) Ctrl + V   b) Ctrl + C   c) Ctrl + A    d) Ctrl + S 

12. ____ Command can be used to open a new document.    a) File – new – text document

 b) File – text – New c) File – star writer – new d) none. 

13. In star writer the flashing vertical bar is called ___. 

   a) Marker  b) Pointer c) Key  d) Insertion point 

14. How many sets of scroll arrows in star writer? a) 2  b) 3 c) 4 d) 10 

15. While saving a file for the first time ___ dialog box appears. 

   a) Save as  b) Edit  c) Save d) open 

16.  In star writer how many document can be opened at the same time?     

 a) 1     b) 2     c) 3    d) many 
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17. ____ key deletes the characters to the left of the insertion point. 

   a) backspace b) Delete c) Home d) Insert 

18.  The toggle between type over mode and the insert mode using the __ key. 

   a) Back space b) delete c) Home d) Insert 

19. ___ Command is used to copy the selected text in star writer. 

   a) Edit – copy b) Tools – Copy c) File – copy  d) Format – copy 

20. ___ Command is used to cut the selected text in star writer. 

  a) Edit – cut  b) Tools – Cut c) File – cut  d) Format – cut 

21. ____ is used to search & replace for a particular text in star writer.     

  a) Format – find & replace          b) Insert – find & replace           

          c) Edit – find & replace     d) Edit – search & replace 

22. The shortcut key for cut, copy and paste is ___. a) Ctrl + x , ctrl +c & ctrl + v 

     b) Ctrl + c , ctrl +x & ctrl + v    c) ctrl + x , ctrl +c & ctrl + v    d) ctrl + a , ctrl +c & ctrl + v 

23. The ___ gives the information about the current mode. 

     a) Title bar  b) Tool bar c) Status bar  d) Menu bar 

24. Entering a new data or modifying the existing text in a document is called__. 

     a) Text editing        b) Editing c) Document editing  d) none. 

25. To move down one screen (scrolling) in the existing text in a document press ___ key. 

      a) Page up b) Page down c) Home d) End 

26. The key that helps to move to the beginning of the document is ____. 

      a) Ctrl + End    b) Ctrl + Home      c) End  d) Home 

 

2. Text formatting 

1. ___menu formatting option are available. 

  a) Format b) Tools c) Window d) Edit 

2. ____ feature is used to mark the important portions of the document. 

  a) Formatting b) Highlighting c) Selecting  d) Help 

3. How many types of page orientation in star writer?  a) 2 b) 4 c) 5 d) 6 

4. Click the increase indent icon, the paragraph is indented by __inch.     

 a) 1/2    b) ¼      c) ¾      d) 1 
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5. Which is a set of characters in certain style?  a) Text    b) Symbol c   ) Document    d) Font 

6. ___ font looks professional. a) Fajita  b) Arial c) Wingdings  d) Font 

7. The size of a font is measured in__. a) Pixel b) Points c) Dots d) none. 

8. There are ___ points to an inch. a) 24  b) 48  c) 72  d) 96 

9. A hard return is inserted every time when __ is pressed. 

     a) Enter     b) DEL c) Home d) Insert 

10. ___ key combination is used for justified the selected program. 

      a) Ctrl + E b) Ctrl + J c) Ctrl + L d) Ctrl + C 

11. The __ is a named set of defaults for formatting text, 

      a) Highlighting b) Styles c) Formatting  d) Editing 

12. A negative indenting value will result in a __ indent. 

       a) Hanging  b) right c) left        d) None 

13. Star office default line spacing is ___ line.   a) 1 b) 2 c) 3 d) none. 

14. The formatting option are else be achieved by clicking on ___. 

      a) Edit – character    b) Format – character c) Format – style d) none. 

15. In a certain style a set of characters and number is called as ___. 

     a) Column b) row  c) Font d) Cell 

16. Soft returns are inserted as ___. a) Backspace   b) Comma     c) Line breaks   d) None 

17. The default top and bottom margin is ___ inches.    a) 2.25   b) 2   c) 1.5 d) 1 

18. Bullets & numbering option is available under __ menu. 

     a) Format b) Edit  c) File  d) View 

19. Which of the following is a decorative font?  

a) Fajita       b) Symbol   c) Wingdings      d) Arial 

20. ____ types of alignment in star writer? a) 2 b) 3 c) 4 d) 5 

21. To remove the highlighting select the text and select the ___ from the color palette.   

     a) No highlighting  b) Fill no c) Fill  d) No fill 

22. ___ font style like symbols. a) Fajita b) symbols c) Wingdings  d) Both a & c 

23. ___ option can be used to indent the line of the paragraph. 

  a) First line b) Line spacing c) paragraph  d) Increase Indent. 

24. The default left and right margin is ___ inches. a) 2.25    b) 2    c) 1 d) 1.25 

25. The default alignment of star writer is ___ alignment. 

   a) Left b) Center c) Justified  d) Right 
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26. ___ command is used to indent paragraphs.   a) Tools – paragraph 

   b) Format – paragraph  c) Tools – Character d) Format – character 

27. How many types of formatting options are in star writer?      

     a) 3         b) 2        c) 4  d) 5 

28.  In star writer the key pressed to enter a hard return is ___. 

    a) Space bar b) Enter c) Backspace d) ESC. 

29. ___ Indent is used for numbered lists.         

 a) Hanging    b) Special      c) First line d) Positive. 

30. ____ opens the star office help.  a) F5  b) F4  c) F2  c) F1 

31. Hanging indents are encountered when we type in ____. 

   a) Negative values b) 0 c) Positive values d) Fixed. 

32. By default star writer ___ line spacing the text in the document.  

     a) Double   b) single   c) 1.5  d) Fixed 

 

    

3. Correcting spelling mistakes 

 

1. ___ key is used to open the spell check dialog box. a) F1 b) F2 c) F5 d) F7 

2. The button used to skip the spelling change only for the current word is ___. 

    a) Ignore all b) ignore once c) Change d) Change all 

3. The spelling mistakes can be corrected in ____ ways.  a) 2 b) 3 c) 4 d) Many 

4. Misspelled word is displayed if it is ___.  

    a) Tool bar  b) Dialog box  c) Check box  d) Not in dictionary 

5. What color is used to underline the words that do not match with the words in the  

    Dictionary   In star writer?   a) Red b) Green c) Black d) Blue 

6. The spell check option can be turned ON or OFF by clicking on the ___ icon. 

    a) Open  b) Auto spell check                 c) File    d) Copy 

7. Auto correct option is available under __ menu. 

    a) File b) Tools c) Edit  d) Format 

8. To add the error and its correction to the auto correct list the ___ command is used. 

    a) Tools – Correct     b) Tools – auto correct / auto format c) Help – auto correct  d) none. 
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9. To skip the current occurrence but stop on the next one___ button is clicked in spelling  

    check  Dialog box.  a) Ignore all  b) replace all  c) Ignore d) Replace all 

10. The replacement table is available in ___ tab. 

      a) Replace         b) Exception  c) Auto correct d) Auto format 

11. In the spell check dialog box ___ list displays any alternative spellings. 

     a) Suggestions b) Change c) add  d) Choice. 

12. To add a word to the dictionary ___ button is clicked in the spelling check dialog box. 

     a) Add b) Replace c) language d) Suggestions. 

13. __ is selected for checking the spelling after the document is typed. 

      a) Tools – Spelling – check   b) Format – spell – check   c) Edit – spell – check    d) none. 

14. ___ key pressed to select the spelling command.  a) F2 b) F5 c) F1 d) F7 

15. Which text box is used to enter replacement word in auto correct dialog box? 

      a) With   b) replace      c) Replace with     d) Change 

16. The number of tabs in auto correct dialog box is __. a) 2   b) 5 c) 6 d) 4 

17. The only check box in the auto correct dialog box is ___. 

       a) Whole words only b) Back words c) Text only d) Match case 

18. Star writer uses ___ option to automatically correct some spelling mistakes. 

      a) Auto correct b) Auto spell correct  c) Auto check d) Auto spell 

19. Star writer can ___ the spelling mistakes as the document is being typed. 

      a) F2 b) F5  c) F1  d) F7 

  

 

4. Working with tables 

 

1. ___ key combination is used to move backward through the cells in a table. 

    a) Tab b) Shift+tab c) Ctrl+tab d) page+tab 

2. ___ dialog box can be used to set the width of the column to an exact size 

    a) Table-format b) Insert-table c) Insert-format d) Insert-column 

3. ___ command is used to delete the selected column      a) Table-delete-column

 b)Table-delete-rows c) Table-columns-delete      d)Delete-column 
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4. ___ command is used to insert a table in star writer       a) Insert-table-table     

 b)Table-insert-table   c) Insert-table-rows&columns   d)Table-insert-table 

5. ___ is used to insert more than one rows in the table        a)Table-rows-insert   

   b)Format-rows-insert   c)Format-rows-insert   d)Table-insert-rows 

6. The entire table is selected using the ____ menu 

    a) Edit b) Format c) File  d) Table 

7. ___ is used to insert more than one column in the table        a)Tools-tables-columns   

   b)Format-column-insert       c)Format-insert-column         d)Table-insert-column 

8. The key that helps to move one cell to the right is ____ 

    a) tab b) Home c) Page up d) End 

9. Which key is pressed to delete entries in the table? 

    a) Delete b) Tab  c) Back space d) Ctrl+alt 

10. The simplest way to add a row at a last  row of a table is to press ___ button 

    a) Insert b) Ctrl+Tab c) Shift+Tab d) Tab 

11. ___ command is used to delete the selected table?       a)Table-Delete-Table     

  b)Format-Table-Delete     c)Format-Delete-Table     d)Tools-Delete-Table 

12. ___ key is pressed to resize the column without changing the width of the table in text  

     document?   a) alt+ctrl b) alt      c) ctrl d) shift 

13. The___ icon is the insert table icon in the floating toolbar for insertion function. 

          a) 3  b) 1  c) 2  d) 4 

14. Which dialog box helps in formatting table properties? 

    a) format table b) Table format c) format d) file format 

15. Which key is hold down to resize the row? 

    a) Shift      b) Tab  c) ctrl  d) Alt 

16. ___ command is used to select the column width of the table? 

    a) Table-Table properties b) Table-format c) Format-table d) Table-properties 

17. The icon that combines two or more cells into a single cell_____ 

    a) split cell  b) merge cell  c) line style  d) none 

18. The icon that is used to split a cell into two or more cell into a single cell_____ 

    a) split cell  b) merge cell  c) line style  d) none 

 

www.kalvisolai.com



Palanigounder Higher Secondary School 
 

- 7 - 

 

19. How to make the selected rows in same size?        a) Rows-space equally      

  b) Space-row-equally    c) Format-row-space    d) space equally- row 

20. The total number of icons present in the formatting toolbar is _________ 

    a) 13 b) 12  c) 14  d) 11 

21. Which is the intersection of a row and a column? 

    a) border  b) cell  c) table d) entire table 

22. The table is a grid with the specified number of_____ 

    a) columns&border    b) rows&columns c) rows&borders d) rows 

23. How will u make all columns even?       a) space equally-column     

  b)width equally-column          c)column-width equally       d)column-space equally 

24. The third icon in the floating toolbar for intersection function’s_____ 

    a) Insert table b) Insert column c) Insert border d) none 

25. The command to create  a simple table is______        a) Insert-table-table  

 b) Table-insert-table  c) Table-insert d) Format-insert-table 

26. ___ command is used to insert more than one row in a table 

    a) Insert-table-rows b) Insert-row c) Table-insert-rows  d) Table-rows 

 

5. Page formatting 

 

1. What is the name of the top portion of a page in star writer? 

   a) Title b) Footer c) Header d) Heading 

2. ___ methods are used to change the page margins.  a) 3 b) 4 c) 2 d) 6 

3. ___ is true to insert a page number in a document.        

 a) Insert – fields – page number     b) Format - fields - page number     

 c) Tools- fields - page number        d) View - fields - page number     

4. If the length of the document is more than the width, the orientation is called ____ 

    a) Layout  b) Landscape c) Portrait d) Margin 

5. How many types of page orientations are there? a) 1 b) 2 c) 3 d) 4 

6. The top and bottom margins are __ inch. a) 1 b) 1.2  c) 1.25 d) 1.5 

7. In star writer to display the ruler on the screen select ruler under ___ menu. 

    a) File b) Edit  c) Format d) View 
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8. The default width of  a page in default orientation is ___ inch. 

    a) 8.5” X 11” b) 11 “X 8.25” c) 11” X 8.5” d) 8.5” X 1” 

9. The default page orientation is __. 

    a) Book      b) Landscape      c) Handout d) Portrait 

10. Margins can be changed using ____. 

      a) Page style dialog box b) Ruler c) a & b d) Table formatting toolbar 

11. The default left and right margins are __ inch. 

      a) 1” b) 1.5”  c) 1.25” d) 1.35” 

12. __ menu command is selected to display the page style dialog box. 

      a) Page – format b) Page – style c) Format- Page d) Format – Style 

13. Which area of the ruler indicates the margins top area? 

     a) Black b) White c) Grey d) a & b 

14. Usually the length of a document will be more than the width. This orientation is called  

       ___    a) Page           b) landscape c) Portrait d) Formatting 

15. How many spin boxes are displayed in the page style dialog box? a) 2 b) 3 c) 4 d) 5 

 

 

6. SPREAD SHEET 

 

1.  The intersection of rows and columns in a spread sheet is called ______. 

     a) Cell b) Row  c) Grid  d) Column. 

2.  A formula in spread sheet always begins with ____. a) + b) - c) ^ d) = 

3. Which of the following operators combines two texts?  a) + b) & c) ^ d) = 

4. The function used to find the square root of a number in star calc___     

 a) SQR  b) SQT  c) SQRT  d) SRT 

5. The cells A4, A5, A6, B4, B5 and B6 are referred in a worksheet as _____. 

     a) A4 : B6  b) A1 : B6    c) A1: A6 ; B1 : B6 d) A4 : A6 ; B4 : B6 

6. Which of the following icons is used to generate a scrolling screen with in a worksheet? 

    a) Insert Plug – in b) Insert floating frame c) Insert OLE object d) Insert chart 

7. The active cell in a spread sheet is identified by ____. 

    a) Insertion pointer b) Cell pointer c) Mouse pointer  d) Keyboard pointer 
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8. Which of the following data can be typed into a spreadsheet cell? 

    a) Numbers  b) Text c) Formula d) All of these. 

9. How many columns are there is VisiCalc? a) 63 b) 254  c) 32000 d) 256 

10. Which bars have shortcut icons for frequently done tasks in the spread sheet? 

     a) Menu bar b) Formula bar c) Object bar d) Main tool bar. 

11. Which key is pressed while editing the contents in a cell?  a) F1 b) F2 c) F5 d) F7 

12.  The operator < > is used to check ___.         

 a) Equal       b) Greater than  c) Less than   d) In equality 

13. Which of the following formula calculates the sum of the numbers in the cell A1 of        

      sheet 1  And A2 of sheet 2?      

     a) = sum (sheet1.A1 + sheet2.A2)  b) = sum (sheet1.A1; sheet2:A2) 

     c) = sum (sheet1.A1; sheet2.A2)  d) = sum (sheet1.A1; sheet2.A2) 

14. Which icon provides a scrolling screen with a worksheet? 

     a) Insert floating frame b) Insert OLE object  c) Insert Applet d) Insert formula 

15. The format for entering date in star calc is___.        

 a) yy/mm/dd    b) yy/dd/mm    c) dd/mm/yy d) mm/dd/yy 

16. Which facility of star calc helps to format the worksheet with different predefined  

      styles an   Colors?  a) Chart b) Auto format c) Applet d) Multiple sheets. 

17. The bar used to displays the current cell and its content is ___ bar. 

      a) menu  b) Object c) formula d) function 

18. The option under the file menu used to quit the  star office is ___.      

 a) Close  b) Quit      c) exit    d) End 

19. A continuous group of cells in a worksheet is called ____.       

 a) Column     b) Row     c) Data sheet d) Range 

20. Graphic representations of numbers are known as _____. 

      a) Charts  b) Graphs c) Bar diagrams d) Cells. 

21. To do the calculations for different worksheet in a particular sheet, we use____. 

      a) 2D formula  b) Function  c) 3D formula d) Selection 

22. The cell referencing that does not get changed when copied is ____. 

      a) Relative cell addressing b) absolute cell addressing c) Reference    d) Comparative. 
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23.  The bar used to display the current cell and its contents in starcalc is ___. 

       a) Menu b) Object c) Formula d) Function 

24. Which is the following is the reference operator?    a) % b) < > c) & d) ! 

25. The pointer that identifies the active cell in a worksheet is ____.  

       a) Cell pointer   b) Insertion  c) Keyboard  d) Mouse 

26. Fill command in star calc is available under the menu___.      

 a) Edit  b) Format  c) File  d) View 

27. The first electronic spread sheet is ____.           

     a) Visi calc       b) Star calc  C) Lotus  d) Excel. 

28. Which of the following operator combine cell areas in starcalc? 

      a) Reference b) Comparative c) Text d) Arithmetic 

29. Non numerical entries are called ____.              

  a) Text     b) Characters  c) Labels d) all of these 

30. The ___ command is used to generate a series.  

      a) Edit b) Series – Down     c) Series – Left  d) Fill 

31. ___ & ____ reference operators in star calc.  a) : , ! b) ; , !     c) * , = d) none. 

32.  A continuous group of cell in a worksheet is called ____.  

     a) Range  b) Group c) Set of cells d) Set of rows. 

33. A cell address can be made absolute by using the ___ sign in front of rows and   columns      

     Names.     a) $   b) 3   c) *  d) % 

34. The cell can hold upto ____ characters.      a) 255      b) 257 c) 258 d) 256 

35.  Which cell address, do not change when copied?         

  a) Relative   b) Absolute  c) Range d) a or b 

36. Which operator is used to refer range in star calc?      a) !      b) : c) ^ d) & 

37. ___ icon is used to import data from different file ULR into a worksheet. 

     a) Plug – in b) Applet c) OLE object  d) Image 

38. If the data entered in a worksheet is a number the program recognizes it as a ____. 

     a) Text b) Number  c) Label d) Integer. 

39. In order to edit , data in a worksheet ____ keys is used. a) F1    b) F2   c) F4 d) F7 

40. ____ Icon is used to import objects from other applications into a worksheet? 

    a) Insert OLE object b) Insert plug – in  c) Insert floating frame d) none. 
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41. Which one of the following arithmetic operators is meant for exponentiation?     

 a) * b) ^ c) / d) % 

42. The operator that combines two text as a single text is___. a) = b) & c) + d) | 

43. To enter the same formula or data in various cells we can use ___ feature of star calc. 

      a) Copy & paste icon  b) automatic fill c) fill series  d) fill 

44. Star calc has a wide variety of ____.              

  a) Formula       b) options    c) buttons    d) functions. 

45. Improve is a product of ___.            

 a) Lotus corporation   b) Sun micro systems     c) Borland d) Microsoft  

46. To draw in spread sheet click_____. 

     a) Insert picture icon  b) Color icon c) Draw d) Show draw function icon 

47. ___ Icon is used to insert an image from image editor. 

     a) Insert image editor  b) Insert applet c) Insert OLE  d) Insert chart. 

48. We can enter time in the form of ___.          

 a) HH : MM : SS       b) SS : MM : HH        c) MM : SS : HH      d) MM : HH : SS 

49. ____ operators return numerical results.            

  a) Text b) Comparative c) Arithmetic d) Reference. 

50. To change the column width click on_______.    a) Format – width – column  

     b) Column - Format - width    c) Format - Column – Height   d) Format - Column - width 

51. A spread sheet contains ____ sheets.     a) 4 b) 5 c) 6  d) Multiple. 

52. ____ are built in formula. a) Values b) Range of cells c) Functions d) Library 

53. Which option of file is used to view a worksheet before printing? 

    a) Print preview          b) Open c) Page view  d) Save 

54. To separate two different sheets in a formula ___ is used.        

  a) Colon b) Hyphen c) Semicolon d) Comma 

55. A data file created using spreadsheet is called____          

  a) Worksheet b) Application file  c) file  d) Project 

56. The number format currency icon displays contents with ___ decimal digits.      

   a) 1  b) 2  c) 3  d) 4 

57. ___ icon displays the contents of the selected cells in currency format. 

    a) Number format : dollar     b) Number format : currency   c) Number format : pound

 d) none 
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58.  ___  is the short cut icon on the formula bar that can be used to insert function 

    a) Function  b) Autopilot  c) Function Autopilot d) Insert function 

59. Auto format option is available on the ___ menu.           

  a) File      b) Edit   c) Format d) Style. 

60. A ___ lets you create a value in one cell that is calculated based on the values in other  

      cells.   a) Text b) Value c) Formula d) All the above. 

 

 

7. DATABASE 

 

1. Which of the following is not a valid data type in star base? 

   a)  Character b) Boolean c) Picture d) Real 

2. Which field is used to uniquely identity a record in a database table? 

   a) Many key  b) Primary key  c) Common key d) Key 

3. Which database type contains single data table? 

   a) Hierarchical b) Relational  c) Flat – file  d) Network 

4. Which of the following option is used to remove the filter? 

   a) Remove filter b) delete filter c) Remove filter / sort d) Delete filter / sort 

5. What is the name of the process for joining data from two or more tables? 

   a) Joining  b) Editing c) Merging d) Adding 

6. What is the name of the screen that displays the fields of record in a well spaced our     

    manner?    a) Report  b) Form c) Query d) Filter 

7. Which of the following are two types of reports?    a) Static and Dynamic  

    b) Static and primary       c) Primary and Secondary    d) Dynamic and primary 

8. What is the name of a set of data for each database entry? 

   a) Field b) File c) record d) Table. 

9. Which language is used to query the database?   a) C++ b) SQL c) HTML d) C 

10. SQL stands for___.   a) Structured Query language b) Sorted Query language  

    c) Sorted Question language  d) Structured Question language. 

11. The field type that is not allowed by star base is ____.   a) Text     b) Binary c) Project

 d) Image. 
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12. The computer that primary use the hierarchical database are ____. 

      a) Super b) Mainframe c) personal d) Mini 

13. The team data is derived from the word_____.         

 a) Datum     b) datem    c) Datas   d) Datus. 

14. A column in a star base table represents a ___.          

 a) Structure      b) File     c) Field   d) record. 

15. The process used to select the desired and specific data from a database is ___. 

      a) Merging  b) Sorting c) Editing d) Searching 

16. In set of processed data is called ___.             

 a) Data b) datum c) Information d) Database 

17. Each row in a database table represents ____.          

  a) File b) Record c) Field d) Table. 

18. A database that contains of a single data table is ____. 

      a) Relational   b) Flat – file  c) Hierarchical d) Network 

19. Which is a type of query?   a) Table b) Forms c) Filter d) Report 

20. How many steps are there in the report wizard window?       

 a) 6  b) 7  c) 8  d) 9 

21. What is a way of limiting the information that appears on screen? 

     a) Searching  b) Filtering  c) Merging  d) Report 

22.  Hierarchical database was primarily used on ______ computers 

     a) Super  b) Personal  c) Micro d) mainframe 

23. Which icon is used to remove the sorting in star base? 

     a) Delete Filter / sort icon b) Delete sort icon   c) Remove sort / filter icon   d) none. 

24. In star base, which is printed information that is assembled by gathering data based  on  

     user   Supplied  criteria?   a) Filter  b) Query c) Form c) Report 

25. Which of the following are users constructed statements in star base? 

    a) Filters  b) queries c) Forms d) Report 

26. DBMS is an acronym for ___.              

 a) Database maintaining system      b) Database management system     

 c) Database manipulating system       d) Database merging system 
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27. Which of the following is also a special type of query?        

 a) Form     b) report   c) Filter d) Question 

28. Which of the following is not a step in data processing? 

     a) Collection b) Verification c) Computation  d) Validation 

29. The number of field types used in star base is ____. a) 20 b) 30 c) 12 d) 13 

30. The filter used with a condition is called ___ filter.          

 a) Auto b) Sort    c) Default    d) Remove. 

31. In database, which option is used to define the maximum size of a field? 

       a) Default value  b) Length c) Type d) Value 

32. Which involves data collection, verification, validation and report generation? 

      a)  Data b) Data processing  c) Database  d) Table 

33. In which computers Hierarchical database structures were used? 

      a) Mini b) Micro c) Mainframe d) Super 

34. The numeric data type can be ___. a) integer b) float      c) Date d) All the above 

35. Users can define their own data types called __ data type.  

       a) Built – in b) System defined c) user defined d) primitive 

36. ___ is a set of processed data that convey the relationship between data considered. 

       a) Information  b) Data c) Datum d) Program 

37. If we use a computer to prepare, store, process and print the data, we call it as ___  

      data    Processing.    a) Data   b) manual c) Hand d) Computerized 

38. The processing speed is fast in __ data processing.  

      a) Computerized       b) Manual  c) Both a & b  d) either a or b 

39. In computerized data processing, it is easy to edit the data including ___. 

       a) Correction b) Change c) Modification D) All the above 

40. Manipulating of a database includes ____. 

       a) Sorting          b) Merging  c) Editing d) All the above 

41. Editing is the process of ____.     a) Adding new data b) Deleting the existing data             

       c) changing the format    d) all the above 

42. Based on the conceptual structures, the data bases can be classified into ___ types. 

 a) 3     b) 2      c) 4     d) 5 
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43. The ____ database structure is the most prevalent database in today’s business  

       organizations.  

     a) Flat – file  b) relational  c) Hierarchical         d) Object oriented 

44. In ____ databases, records are organized in a tree like structure by type. 

       a)  Hierarchical  b) Relational  c) Network  d) Flat file. 

45. ____ database is useful for certain single user or small group situations. 

       a ) Relational b) Flat file c) Hierarchical  d) Flat file. 

46. The ____ database is similar to the hierarchical structure excepts that any one type can  

       relate To any number   of types.   

a) Network  b) Object oriented  c) flat file d) relational 

47. An object is defined by its _____.  

a) Attributes  b) Characters     c) Procedures d) all the above. 

48. The data management tasks in a DBMS fall into one of the ___ categories.     

  a) 2      b) 3 c) 4 d) 5 

49. The data management tasks in a DBMS involves____.       

a) Entering data into the database   b) Reordering records in the database.     

 c) Obtaining subsets of the data  d) All the above. 

50. __ provides the means for multiple users to access and share data in the same database  

     by    way   Of  networked systems.              

 a) Star calc  b) Star base  c) DBMS d) Ms – office 

51. In star base window, the ____ pane displays tables, queues, forms, and report. 

       a) Right   b) Left  c) Top  d) Bottom 

52.  In star office base window, on the right top is ____ pane. 

     a) Tables  b) Forms c) Tasks d) Reports. 

53. Once the database is created, the next step is to create the _____. 

       a) Data  b) Tables c) Related tables d) Reports 

54. Using tables, star office base allows us to ______. 

       a) Design forms b) Query the database c) Prepare reports d) All the above. 

55. We can also give a brief description of the contents of the _____. 

       a) Table  b) Record c) Field d) database 

www.kalvisolai.com



Palanigounder Higher Secondary School 
 

- 16 - 

56. Star base allows us to use ____ different field types.         

  a) 5  b) 10  c) 20  d) any number 

57. ____ accepts small integer’s upto a few thousands. 

         a) Integer  b) Small integer  c) Tiny integer        d) Big integer 

58. ____ Data type accepts only whole numbers.          

   a) Integer  b) Decimal  c) Real       d) Image. 

59. Single precision decimal values are accurate upto a length of ___ places.      

  a) 5      b) 7  c) 9  d) 14. 

60. Double precision decimal values are accurate upto a length of ___ places.  

a) 7     b) 14  c) 28  d) 56. 

61. While designing the table we enter values for the ____. 

        a) Field name b) Field type c) Description       d) All the above 

62. ____ option is used to specify the maximum characters that can be entered in that  field.      

        a) Entry required  b) Length c) Default value d) Size of the field. 

63. ____ menu is used to modify the table design.          

  a) File  b) Format  c) Edit  d) Insert 

64. After entering the records into the table star base allows you rearrange them by   ____.     

       a) Merging b) Filtering c) Searching  d) Sorting. 

65. To display the records in the original order, click on___. 

      a) Unsort icon b) Filter icon c) Remove sort/filter icon d) any of the above 

66. The language, supported by DBMS is____. a) C++ b) Java c) SQL d) ADA 

67. ___ are special views of the data in a table.     

 a) Database     b) Sorting     c) Queries    d) Reports 

68. The output from a____ does not affect the original table.   

 a) Table  b) Sort c) Query d) Data 

69. The first step of query wizard is ____.    

a) Field selection      b) Sorting order  c) Sort wizard   d) Query wizard 

70. A ____ ia a type of query.   a) Sort b) Filter c) Report d) Search 

71. ___ is used to select and display records which match a certain condition. 

      a) Filter  b) Sort c) Report d) Search 

72. Filters ____ be saved for later use.  a) Can b) Cannot c) May d) may not 

73. Star office allows you to use the filters of ____ types.   a) 2 b) 3 c) 4 d) many 
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74. Filter used with a condition is called ____ filter.   

a) Auto        b) Conditional  c) Default d) filter 

75. The filter window is very similar to the one used for specify condition in a ___. 

      a) Sort  b) Report c) Form d) Query 

76. To remove the filter, click on ____ icon. 

      a) Remove filter b) Remove filter/sort c) Remove sort d) Remove default filter 

77. A _____ is a screen that displays the fields of a record in a well spaced out manner. 

      a) Query b) Filter c) Form d) Report 

78. Select the ___ check box in the set up a subform window to insert another form within  

      this   form.    a) Add subform b) add form   c) Insert form  d) insert subform. 

79.  ___ helps us to generate report.  

     a) report wizard b) report auto pilot c) report temple d) report window. 

80. Select ____ in the paste special dialog box, to see the data automatically changes in  the     

      Document, when it  is modified in the spread sheet.    

a) OLE  b) Link         c) Link and paste d) DDE link. 

81. Field types include ____. a) Text        b) Numeric c) Logical d) all the above. 

82. __ and ___ are conceptual model for older systems. 

      a) Flat file, Network b) Hierarchical, network c) relational, object oriented d) none. 

83. Select ____ option on the tasks pane to create a query.       a) Create query in SQL view         

      b) Create query in design view   c) Use wizard to create query     d) Create query. 

84. ____ is defined by its characteristics, attributes and procedures.  

a) Form b) record    c) Object d) File.  

85. Data’s are of ____ types.  a) 3 b) 5 c) 12  d) 10 

86. Star base window is divided into how many panes?   a) 2 b) 3 c) 4 d) 5 

 

 

8. INDRODUCTION TO MULTIMEDIA 

 

1. Which of the following is a computer – based presentation technique? 

 a) Multimedia b) Data processing c) Tutorials  d) Slides 

2. MMS means____.    a) Multimedia service b) Multimedia messaging system  

  c) Multimedia system  d) Multimedia messaging services. 
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3. Which if the following is the most common version of e-learning packages? 

      a) CBT / WBT b) WBT / SMSC  c) CBT / WBT         d) MMS / SMS 

4.  How many image formats are most commonly used?  a) 5 b) 4 c) 3 d) 2 

5. Which file creates a perfect reproduction of the original images? 

a) JPG b) Nx view  c)  Shock wave d) GIF 

6. GIF means ___.  a) Graphic interchange format b) Graphic interchange File 

c) Graphic information file  d) Graphic information format. 

7. Expand JPEG…  a) Joint processor experts group b) Joint photographic experts group 

    c) Joint photographic expression group d) Joint photo experts group 

8. Which image files are a lossy format?  a) JPEG b) GIF c) MPEG d) Nx View 

9. How many categories of image file compressions are there ? a) 4 b) 3 c) 5 d) 2 

10. How many attributes control the characters of sound? a) 2 b) 3 c) 4 d) 5 

11. Which of the following is called frequency?   

  a) Amplitude b) resistance c) pitch         d) modulation 

12.  Conversion of a analog waves to a digital format called____. 

    a) Echo b) Sound forge c) Frequency d) Modulation 

13. Which of the following animations are also referred to as slide or path animations? 

   a) Cel-based animations  b) Object based animations   c) 3D animation   d) 2D animation 

14. How many step process for creating a 3D animation?  a) 2 b) 4 c) 3 d) 5 

15. Which of the following is not a step to create a 3D animation? 

     a) Modeling b) Animating c) Rendering d) Acessing 

16. Which of the following is a technique to blend 2 or more images to form a new image? 

     a) Warping b) Morphing c) Modeling  d) Animating 

17. How many frames per second causes the video to look jerky?  

 a)< 9      b) < 10     c) < 15    d) < 20 

18. How many color depth results in the image looks murky?  

  a) < 225  b) < 16      c) < 256 d) < 8 

19. How many types of video compressions?  

a) 3  b) 2  c) 4 d ) 6 

20. Which compressions provide some loss of quality?  

a) Loss less    b) Cel – based    c) Lossy  d) Object – based 
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21. MIDI stands for _______.  

    a) Musical instrument digital interface      b) Musical interface digital instrument 

    c) Modeling instrument digital interface      d) Modeling interface digital information 

22. Which year the MIDI format was developed?  a) 1972 b) 1982 c) 1984 d) 1974 

23. Which sound format cannot contain sounds? a) wave b) AIFF c) AU     d) MIDI 

24. The real audio format have the extension___.     

   a) rm or .rf b) .ram or .rf c) .rm or .ram d) .rm  or .rad 

25. What is the extension of Au format sound file?  a) .AUD     b) .AU    c) .AUD   d) .ADO 

26. AIFF stands for _____.    

   a) Audio interface format file   b) Audio Interchange file format 

     c) Au interchange file format  d) Audio information file format 

27. What is the extension of AIFF format files?       

a) .aif or .af     b) .aiff or .aid    c) .aiff or .aif    d) .aid or .aif 

28. What is the extension of SND format sound file? a) .sn     b) .sdn      c) .sou       d) .snd 

29. What is the extension of Wave format sound file? a).wva    b) .wav      c) .wave    d) .dat 

30. MPEG stands for…… 

    a) moving pictures experts group      b) Model pictures expression group 

    c) moving pictures expression group  d) morphing pictures experts group 

31. What is the extension of MP3 & MPGE format sound file?      a) .mp3 or .mpeg 

 b) .mpeg or .mpga  c) .mpge or .mpg  d) .mpg or .mpeg 

32. AVI stands for ……… 

     a) Audio video interface   b) Audio video information 

     c) Audio video interleave   d) Audio video interchange 

33. What is the extension of AVI  format sound file?  

a) .AV        b) .AU c) .AVI  d) .AIV 

34. Sounds and video in multimedia applications can be played by using ___. 

     a) Inline or helper b) inline or outline c) helper or outline d) inline only 

35. Which tag is used to add in line sound to a web page? 

     a) <inline>  b) <be sound>  c) <sound> d) <helper> 

36. _____ tag is used to launch helper application.     a) <embed> / <applet>  

     b) <applet> / <object> c) <embed> / <applet> / <object>       d) <embed> / <object> 
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37. ___ graphs helps in rendering the image effectively on the screen. 

     a) image B) Static c) Vector d) Scalar 

38. What is the name of the process for converting analog waves to s digital formatting? 

     a) sampling b) Sound forge c) Amplitude  d) Frequency 

39. Name the technique that blends two or more image to form a new image. 

    a) blending  b) Warping  c) Morphing d) modeling 

40. Which of the following is the commercial multimedia content development software  

     _______.    a) Flash  b) Dream weaver   c) Maya d) All of these 

41. The technique that provides an environment experienced by users as similar to reality is  

      ______. a) Virtual reality b) Vector graphics      c) Animations  d) modeling 

42. Name of the technique of distorting a single image to represent something else is ____. 

      a) Modeling  b) rendering  c) Morphing  d) Warping 

43. The sound that we hear are ____ wave patterns. a) analog b) digital c) hybrid d) pitch 

44. In ___ doctors can get trained by viewing at a virtual surgery.  

      a) Engineering b) Medicine c) Scientist d) Online magazines 

45. Two attributes control the characteristics of sound ___.      a) Amplitude & volume 

 b) Frequency & pitch c) Frequency & Wave  d) Amplitude & Frequency 

 

 

       9. PRESENTATION 

 

1. Which key is used to create a new presentation using a template? 

      a) shift + Alt + N       b) Shift + Ctrl + N     c) ctrl + Alt + N     d) Shift+ Tab 

2. Which of the following view allows creating and editing slides?  

a) Normal     b) Outline    c) Notes     d) Handouts 

3. Which command is used to insert a picture in a slide?      a) Insert →  Picture     

 b) Format →  Picture     c) Insert →  Picture → From file    d) Insert → From → Picture 

4. How will you change the background color of all the slide?     a) Format →   Background         

    b) Format → Page →  Background    c) Format → Page     d) Insert → Page →  Background    

5. Which key combination is used to print slides in StarOffice? 

    a) Alt + P  b) Ctrl + P  c) Shift + P  d) Shift + Ctrl + P 
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6. To send text outline into presentation, select ………………..        

  a) File → Sent → Outline to presentation        b) File → Outline to presentation     

   c) File → Presentation                   d) File → Sent → Presentation                                   

7. In presentation the view that allows us to view miniature image of the all slide is ____ 

a)  Slide sorter        b) Master page          c) Notes view          d) Layout 

8. Which of the following is used to import objects from other application into a  

     presentation?        a) Insert ODBC object    b) Insert OLEDB object      

  c) Insert OLE object  d) Insert DBMS object 

9. The shortcut  key  for opening style list is …………….. a) F8 b) F7    c) F5 d) F1 

10. To change the background color  of the current slide, click on……………   

 a) Format → Page →  Background               b) Tools  → Page →  Background      

 c) Edit → Page →  Background         c) View → Page →  Background    

11. The key combination used to open print dialog box in StarImpressOffice is ………….. 

              a) Ctrl + Shift + P       b) Ctrl + P        c) Shift + P     D) Alt + P  

12. The number of option displayed in the first page of the presentation wizard is……..  

 a) 2       b)  3      c) 4      d) 5 

13. Which of the following options display ‘ created with StarOffice ‘ message during the  

      pause  between each  presentation?            

 a) Automatic     b) Effect        c) Show Logo      d) Default 

14. The view used to recorder is …………….            

  a) normal     b) outline      c) notes      d) handouts 

15. To open  media player window,  choose …………      a) Tools-Media player    

        b) Edit-Media player               c) Insert- Media player      d) View- Media player    

16. Which is not a Background fill option ?            

 a) Color       b) Gradient      c) Picture         d)  Hatching 

17. In StarOfficeImpress, the windows allows to quickly jump from one slide to other slide or  

      move between  open  file is ………….     

      a) Desktop         b) Navigator       c) Preview      d) Moving slider   

18. In StarOfficeImpress, which  view allows to view  miniature images of all slides? 

        a)  Slide Sorter        b) Outline     c) Notes     d) Handouts 

19. The keyboard used to create a new presentation using template is …………. 

        a) Ctrl + N       b) Shift + Ctrl + N       c) Alt + N      d) Ctrl + F + N  
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20. Which one of the following displays various  transition effects that can be attached to a  

       slide? 

      a)  Custom animation    b) Slide animation    c) Animation effects  d) Slide sorter 

21. Which button is pressed to start the slide show in StarOfficeImpress?    

  a) F1 b) F3         c) F5           d) F7 

22. In StarOfficeImpress, to start a presentation, press …………..        

a) F5           b) F1          c) F2            d) F3 

23. To rename a slide choose slide  →  ………………… 

     a) rename slide    b) new slide    c) rename     d) slide rename 

24. To open style list in presentation, press ……..    

a) F10             b) F11             c) F12             d) F13 

25. Which of the following views allows to record slides, edit slide titles and heading? 

      a) Normal view     b) Notes view   c) Handouts  view     d) Outline view 

26. Which of the following commands is used to open HTML export view? 

     a) File - Export    b) HTML - Export     c) File - HTML Export     d) File - HTML Export 

27. …………. Is the Star Office application that allow us to create attractive presentations. 

     a) Star Office Impress    b) Star Office Writer      c) Star Office Draw    d) Star Office Calc 

28.  To change the slide order, in the switching presentation view tab click ………… 

        a)  Slide Sorter        b) Layout        c) Outline         d) None of these 

29. To produce HTML  presentation choose……………….. 

      a) File-HTML     b) File-Export        c) Edit-Export      d) Edit-HTML 

30. Which key combination is used to print slides in star  office? 

      a) Alt + P         b) Shift +  P           c) Ctrl + P      d) Shift + Ctrl + P 

31. A ……… box on the right allows you to view a preview of the slide with the selected    

      background.  a) preview       b) print      c) speed    d) automatic 

32. The …….. section in the lower half of the page  allows you to specify the final output   

      medium for presentation. 

   a) output medium      b) slide       c) select an output medium   d) select a medium 

33. The ……… page of the wizard allows you to specify  the transition effects to be used in   

     presentation.     a) first b)second c)third   d)fourth 
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34. The select a slide transition section at the  ………… of the page allows you to choose the  

      Transition   effect and speed in the slides.     

    a) bottom      b) right top corner      c) top      d) left 

35. To create a new presentation  using a template, choose ……….          

 a) File → New → Presentation                     b) File → New → Template      

 c) File → New → Document      d) File → New → Templates and documents 

36. StarOffice Impress allows us to …….. and modify Microsoft  Powerpoint presentation. 

       a) import             b) export          c) report            d) compile 

37. StarOffice Impress  Window contains  …………. Panes       a) 2       b) 3        c) 4     d) 5 

38.  The task pan on the right displays  ………… pages   a) 2       b) 3      c) 4         d) 5 

39. ……. Page of the tasks plan displays various transition effects that can be attached to a  

      Slide   a) Custom animation    b) Slide Transition      c) Layout        d) Master 

40. ………..  view allows to recorder, edit slide titles and headings. 

    a) Normal         b) Notes           c) Handout          d) Outline        

41.   ………….  View is used by a presenter to add additional information to a slide 

     a) Notes           b) Handout          c) Outline        d) Layouts 

42. We can choose a ………….  While  creating   a new slide.  

a) Notes    b) Layout     c) Outline        d) custom 

43.  ……….. menu is used to start a presentation.    

  a) View          b) Tools           c) Slide Show        d) Window 

44. Press ……….. key to start a presentation     a) F1     b) F2       c) F5         d) F7 

45. The onscreen presentation starts automatically in the …………… mode 

      a) minimized       b) full screen       c) maximized        d) normal 

46. End the presentation by pressing the  ………………… key  

       a) End          b) Enter           c) Esc           d) Break 

47. …………   key is used to stop the presentation  before end.  

      a) End          b) Enter           c) Esc           d) Break 

48. Select  ………  to run  a custom slide show in the order that you defined. 

       a) Slide Show       b) Custom Slide Show    c) View Show    d) any the above 

49. The new slide uses the page layout of the ………………. Slide 

      a) first              b) previous       c) last       d) any of the above 
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50. To insert  a picture  in a slide,  choose ………..                  

a)  Insert → From File → Picture                      b) Insert → Picture→ From File      

c) Format→ From File → Picture                      d) Format→ Picture → From File 

51. To define the order in the slide show, click on ……….. 

       a)  slide show         b) view show        c)  custom slide show       d) outline 

52. To insert movie in a slide, click on ……………..          

a) Insert → Picture Sound                 b) Insert → Audio and Video             

 c) Insert → Movie and Sound            d) Insert → Picture and Sound 

53. To play a movie or sound file click play on the ………. Tool bar 

      a) Movie     b) Sound       c) Media       d) Media Playback 

54. For movie files, the bar contains a list box where we can select the ……… for the 

playback. 

      a) volume slide     b) zoom factor     c) position slider    d)  any of the above 

55. The media player supports  …………………  different media formats    

        a) 2          b) 3       c) 4      d) many 

56. To insert an object in a slide, choose ………… 

      a) Insert → Object        b) Insert → Chart      c) Insert → OLE      d) Insert → Formula 

57. Insert OLE object is used to import objects like ………………….. 

     a) Formula    b) text    c) Microsoft application objects         d) all the above 

58.  Click ………… to get slide view         

  a)  Insert → Toolbar → Slide View              b) Insert → Slide View               

  c) View → Slide Show    d) View → Tool Bars → Slide View 

59.  The objects in your slide can have ……………   effects    a) 2     b) 3     c) 4      d) many 

60. A ………  determines the text formatting style for title outline and the background for one  

       or   for all of slides 

     a)  slide        b) master        c) slide design             d) slide background 

61. The styles outline one through outline ………. Enables  you to give the outlined headings  

      and topics on your   slides a uniform look         a) 8 b) 9  c) 7  d) 6 

62. Open stylist by choosing ………………     a) Format → Styles and Formatting           

 b) Format → Styles       c) Tools → Styles and Formatting            d) Insert → stylist 

63. Open  stylist with the …………… key     a) F5    b) F7    c) F11      d)  any of the above 
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64. If you want a slide show always with current page, use …………… 

     a)  Edit → Options → StarOffice Impress      b) Tools → Options → General 

     c) Slideshow → Options→ StarOffice Impress → General    

    d) Tools → Options → Staroffice Impress → General 

65. Choose …………  to hide a slide in the slide show       

  a) Tools→ Show/Hide slide           b) Insert → Show/Hide Slide              

  c) Slide Show → Show/Hide Slide        d) any of the above 

66. Using the ……….. you can move from slide to slide quickly 

     a) Navigator        b) Presentation      c) HTML       d) Any of the above 

67. Open navigator by choosing  ……….. menu        

a) View       b) Insert           c) Edit             d) Format 

68.  Select ………. Colors to apply the colors supported by browser 

          a) use HTML     b) use HTTP         c) use browser      d) use link 

 

Volume  II 

1. Object oriented concepts using C++ 

 

1. ___ is a tool to solve a wide range of problems 

2. a) Computer b) Calculator c) Abacus d) CPU 

3. The solutions to the problems are in the form of computer program or ____. 

4. a) System software b) Application software c) Hardware d) Software 

5. ___ Statements provide instructions to the computer on the operations that need to be 

performed on the data items.             

  a) Control      b) Assignment  c) Looping  d) Unconditional 

6. A group of the data and the operations are termed as _____ 

7. a) Object b) data c) Function  d) Operations 

8. The operations represent the _____ of the object. 

9. a) Behaviour  b) Data c) State d) Function 

10. Which is a kind of a self-sufficient subprogram with a specific functional area? 

11. a) Object b) Inheritance c) Functions  d) Encapsulation 
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12. The mechanism by which the data and functions are bound together within an object 

is called as____. a) Overloading b) Overriding c) Encapsulation  d) polymorphism 

13. The ability of an object to respond differently to different message is called ____.                       

a) Function b) Polymorphism  c) Draw( ) d) Overriding 

14. The process of acquiring base class properties is called _____.                                                      

a) Inheritance  b) Class c) Polymorphism d) Object 

15.  The ___ are power packed, as they include the functionality of the base class                     

 along with its own unique feature.                                                                                                               

 a) Derived classes b) Base class  c) Class d) Object 

16.  ____ allows a class to be derived from an existing class.                                                                              

a) Polymorphism b) Inheritance c) Encapsulation  d) Object. 

17.  The derived class are ____ Packed.                                                                                                     

  a) Completely  b) Uniquely  c) Power d) Cover 

18.  A template for entities that have common Behaviour is ____                                              

a) Class  b) Object  c) Methods  d) Attributes 

19.  C++ belongs to which category of programming language?                                             

 a) Structured     b) Object oriented   c) modular  d) Procedural 

20. The group of data and operations together are known as ______                                    

  a) Class  b) Function  c) Structure  d) Object 

21.  Which one operates on a set of known input data items?                                                            

 a) Computer program b) human ware c) System d) output data 

22.  _______ statements provide instructions to the computer on the operations that need 

to be performed on the data items.                            

 a) Control b) Assignment c) looping d) Unconditional 

 

 

2. Overview of C++ 

  

1. C++ was developed by ____. a) James Goling  b) Bjarne stroutstrup                               

 c) John Kemney d) Thomas kushz 

2. Rick Masciti coined the name _____. a) C++ b) BASIC c) COBOl d) Visual 
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3. The basic types are collectively called as ____.                                                                              

a) Token b) Variables    c) Characters  d) Variable  

4. ____ is the smallest individual unit in a program.                                                           

 a) Token b) Character  c) Control  d) Variable  

5. Which one gives special meaning to the language compiler?                                           

  a) Compiler  b) Keywords  c) Variable d) Constants 

6. ____  modifiers allows the variable to exist in the memory of the computer, even if its 

function or block looses its scope. a) auto   b) static    c) extern   d) register 

7. Which one holds the values or constants in memory boxes?      

 a) Variable  b) While c) Switch d) go to 

8. The ____ symbol is used to declare a pointer variable. a) * b) &     c) #   d) / 

9. What are the assign bitwise assignment operator? a) &=   b) ^=   c) 1=   d) all 

10. Built in data type is also called as ____ datatype.       

 a) Fundamental  b) Secondary c) Integer d) Void 

11. Static and register variables are automatically initialized to ____ value when they are 

declared ______ a) 1 b) 2  c) 3  d) 0 

12. _____ type is further divided into int and char.       

  a) Integral  b) Int  c) Char d) Float 

13. When a=5,c=-- what will be the value of c?  a) 5 b) 6 c) 4 d) 8 

14. What type of integer starts with OX?         

 a) octal b) Hexadecimal  c) Binary d) decimal 

15. ____ Data types are structure, union, class and enumeration.     

 a) User defined b) Built-in c) Derived d) Integer 

16. The constant that should not have fractional part is ______.     

 a) Float b) Double c) Integer d) Exponent 

17. How many operators are classified in C++?  a) 11  b) 13  c) 14  d) 15 

18. How many fundamentals data types are there in C++? a) 1   b) 2     c) 3    d) 4 

19. Which is the conditional operator? a) ?    b) >      c) <    d) ?: 

20. The operands and the operators are grouped in a specific logical way of evaluation is 

called…….  a) Class   b) Association   c) Assignment    d) Arithmetic 

21. When a = 6 and c = a++ what is the value of c?   a) 6 b) 7 c) 8 d) 5 
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22. What will be the value stored in C when a = 20,b=20, c(a<b)?a*a:b%a;______ a) 

 a) 0 b) 400 c) 40  d) 20 

23. Which punctuator is used to terminate a C++ statement?  a) ;   b) :   c) *  d) , 

24. How many C++ data types are broadly classified?  a) 2    b) 3     c) 4    d) 5 

25.  ___ data type enables to invent his own data type define values   

 a) User defined b) Derived     c) Floating d) Integral 

26. ____ allows users to define the user defined data type identifier.   

 a) Type definition b) Identifier c) Data d) Class   

27. ____ data types helps users in creating a list of identifiers    

 a) Int        b) Float c) Char d) Enumerated 

28. ____ class is another qualifier that can be added to a variable declaration     

 a) Storage  b) Sub c) Static  d) register 

29. Static register variables are automatically initialized to ____ value when they are 

declared.    a) 1 b) 2  c) 0  d) 3 

30. Auto variable get undefined values known as _____      

 a) Garbage  b) Auto c) Register  d) Static 

31. ____ Storage class defines local variable known to the block in which they are 

defined?   a) Static b) Auto c) Extern d) register 

32. Storage class variables defined with in a function or a block cease to exist, the 

moment the function or block looses its scope____.      

 A) Auto b) Static c) Extern d register 

33. ___ Modifiers allows the variable to exist in the memory of the computer, even if 

its function of block looses its scope. A) Auto  b) Static c) Extern d register 

34. ____ storage class global variable known to all functions in the current program  

 a) Auto b) Static c) Extern d register 

35. ___ storage class variables are defined in another program.     

 a) Auto b) Static c) Extern d register 

36. Built in data type is also called as ____ data type       

 a) Fundamental b) Secondary c) Integer d) Void 

37. How many storage specifiers are there in a C++? a) 3 b) 4 c) 5 d) 3 
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38. ___ type is used to declare a generic pointer in C++.      

 a) Float b) Void c) Static d) Int 

39. Signed, unsigned, long and short are some of the ____.     

 a) Data b) Derived data c) Modifiers d) Void 

40. What is the range for char data type in C++?       

 a) -126 to 127   b) 128 to -127  c) -128 to 127    d) -127 to 128 

41. What is the range for int data type in C++?       

 a) -32767 to 32768   b) -32768 to 32767  c) 32768 to 32769    d) 32767 to -32768 

42. The long int, signed long int has ___ bytes. a) 2 b) 4 c) 3 d) 8 

43. ___ is a variable that holds a memory address.       

 a) Pointer b) Char c) Float d) Long double 

44. Integer values are stored in ___ bit format in binary form.    

 a) 8  b) 16  c) 32  d) 64 

45. ___ bit is also called as the most significant bit or sign bit.    

 a) 15th b) 16th c) 18th d) 19th  

46. The 16th bit will have a value ___ if negative value is stored. a) 1 b) 0 c) -1 d) 2 

47. The unsigned char, and char data types has____ bits.a) 8  b) 16 c) 32 d) 64 

48. What is the length of double data type? a) 32 b) 8 c) 16 d) 64 

49. __ is an operator which returns the memory size requirements in terms of bytes. 

a) size of( )  b) Long c) Size d) Double 

50. In an examble long double a; int b; a=6,b=4 what is the output of size of (a*b)?

 a) 8 b) 10  c) 4 d) 2 

 

3. Basic statements 

1. How many methods are there for assigning data to the variables in C++?   

 a) 2 b) 3 c) 4 d) 5 

2.  Data is read from the keyboard during run time by using the object____   

 a) Cin  b) cni  c) nci d) nic 

3. The declarations for the object cin are available in header file called as____.  

 a) istream.h  b) istream c) stream.h d) stream 
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4. ____ file comprises of all standard declarations and definitions for predefined functions.

 a) Header b) Footer c) istream d) iostream 

5. Program statement that causes jumps are called as ____ statements or structures 

 a) Control b) assignment c) increment d) decrement   

6. The multiple branching statement is _____ statement.      

 a) If b) Switch c) For  d) While 

7. How many kinds of loops are there in C++?  a) 1  b) 2 c) 3 d) 4 

8. A loop embedded within another loop is called____.      

 a) Nested b) Loop c) Break d) Continue 

9. A program written in high level language is called as ____.     

 a) Object code b) Source code c) Executable code d) All of these 

10. How many times the following loop will be executed? For(i=1;i<6;i++)   

 a) 1 b) 5 c) 6 d) 7 

11. The break statement would exit only____.        

 a) Current loop b) Current function c) Current program d) None  

12. In C++ which file comprises the combined properties of istream and ostream?  

 a) stdio.h b) string.h c) conio.h d) iostream.h 

13. Which of the following functions will be executed first automatically, when a C++ 

program is executed? a) Void   b) Main    c) Recursive d) Call by reference 

14. Which of the following statements marks the end of the function and also transfers 

control to the statements after call statements?       

 a) Return b) Break c) Continue  d) Headera) Editor b) Linker c) Compiler 

 d) header 

15. Which of the following functions will be executed first automatically, when a C++ 

program is executed? a)Void b) main c) Recursive  d) Call by reference 

16. How many times the following loop will be executed ?            

            Int ctr = 1; 

 for(;ctr<10;ctr++) 

 { 

 Cout<<ctr; 

 } 

a) 1 b) 10 c) 11 d) 9 

www.kalvisolai.com



Palanigounder Higher Secondary School 
 

- 31 - 

18 . Find the output 

Int ctr = 1; 

 for(;ctr<10;ctr++) 

 { 

 Cout<<ctr; 

 Ctr = 1; 

 } 

 a) 1 infinitive  b) 1,2,3,4,5,6,7,8,9,10   c) 1,2,3,4,5,6,7,8,9  d) 1,1,1,1,1,1,1,1,1,1 

 

 

4. Functions 

1. ___ are the building blocks of C++ programs.       

    a) Functions b) if – else c) For  d) Switch 

2. The starting point for the execution of a program is ____. 

    a) Main ( ) b) Void ( ) c) Public d) Class 

3. The calling function parameters are called as____ parameters 

    a) Formal b) Actual c) Dummy d) Duplicate 

4. In call by value method, the flow of data is always from the ___ statement to the  

    function definition. a) Call b) return c) function d) go to 

5. In ___ method the called function argument formal parameters become alias to the  

   actual parameter. a) Call by value  b) Call by reference   c) return   d) call 

6. The functions that return no value is declared as ____. 

    a) Null b) Void c) Static d) public 

7. An ____ looks like a normal function in the source file but inserts the functions code   

   directly into the calling program. a) inline    b) online c)  mainline    d) line 

8. To make a function inline one has to insert the keyword ___ in the function header. 

    a) inline  b) online c) mainline  d) line 

9. Inline keyword is just a request to the ____. 

    a) Compiler b) Interpreter c) Linker d) Object 

10. How many types of scopes in C++? a) 2 b) 3 c) 4 d) 5 

11. In __ scope  a local variable is defined is defined within a block. 

      a) File    b) Function c) Local d) Class 
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12. A block of code begins and ends with___. a) { } b) [ ]     c) ( ) d) { ] 

13. ___ scope of variables declared within a function is extended to the function block and  

     all sub blocks therein. a) File    b) Function c) Local d) Class 

14. A variable declared above all blocks and functions has the ____ scope. 

      a) Scope of a file b) Local scope c) Function scope    d) Class scope 

15.  Which of the following is NOT true, related to functions? 

 a) The actual parameters can be passed in the form of constants to the formal  

            parameters of value type. 

 b) The actual parameters can be passed only as variables to formal parameters of  

            Reference type. 

 c) The default value in the formal parameters can be given in the form of variable  

            initialization  

 d) The default value for an argument can be given in between the argument list 

16. In the following code, the scope of the variable a is _______. 

 if(x<y) 

 { 

 Int ; 

 a++; 

 } 

 a) Local scope b) Function scope         c) File scope  d) Class scope 

17. A function can be invoked from another function using its__________ 

 a) Variables  b) Name c) return d) Value 

18. Which function executes faster but requires more memory space? 

 a) Normal function  b) Void function   c) Regular function   d) Inline function 

19. The scope of any variable used in the entire program is ____ 

 a) Local b) File c) Function  d) Class 

20. The return type of the function prototype float powert(float,int) is ___. 

 a) Char b) Double c) int  d) float 

Read the following coding and give the answer 

#include<iostream.h> 

 int n1=10; 

 void main() 
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 { 

 int n2 =20; 

 if(n1>n2) 

 { 

 int temp;temp=n1;n1=n2;n2=temp; 

 } 

 Cout<<’\n’<<n1<<’\n’<<n2; 

 } 

21. file scope_______. a) n1 b) n2  c) temp d) None of these  

22. Function scope _______. a) n1 b) n2  c) temp d) None of these 

23. Local scope _________. a) n1 b) n2  c) temp d) None of these 

 

 
5. Structured Data types – Arrays 

 
1. An ____ is a collection of variable of the same type that are referenced by a common  

   name. a) Variable b) constant  c) array d) program 

2.  Arrays are of ____ types.   a) 3 b) 4 c) 2 d) 1 

3. ____ dimensional array comprising of finite homogenous elements. 

   a) 1  b) 2  c) Multi d) 3 

4. ___ dimensional array comprising of elements each of which is itself a one dimensional  

    array.    a) 1  b) 2  c) Multi d) 3 

5. int num_array[5]; is this array how  many integer values can be stored? 

    a) 4 b) 5 c) 6 d) 1 

6. The size of the array should always be ____.         

 a) Positive   b) negative    c) whole number    d) real number 

7. Each element of the array is accessed by the _____ name and position of the element in  

    the array.    a) Array b) variable c) Dimensional  d) Subsciript 

8. int days [ ] = {1,2,3,4,5,6,7); in this  statement, what is the size of the array? 

 a) 6 b) 5 c) 4 d) 7 

9. cin>>number[4]; in this array processing which reads the ___ elements. 

 a) 4th  b) 5th  c) 1st  d) 3rd 

10. number[3]++ in this array processing which increments the value stored as  
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      _____ element  By 1.  a) 4th  b) 5th  c) 3rd  d) 2nd 

11. The process of arranging the data in a given array is called____. 

 a) Merging    b) ordering c) Filtering  d) Sorting 

12. ____ are otherwise called as literals.  a) Strings b) Constants    c) Variables   d) Data 

13. A character array should be terminated with a ____ character. 

 a) ‘0’  b) ‘\0’  c) ‘0/’  d) \0 

14. ____ is a member function of standard input istream. 

 a) getline() b) get() c) getsline()  d) line() 

15. ____ is a member function of standard output ostream. 

 a) Write() b) Print() c) writes() d) reads() 

16. All member functions  of a class, should be accessed through an ___ of class. 

 a) Object b) Instance  c) A and B d) function 

17. _____ parameters are required for write function. 

 a) 2 b) 3 c) 4 d) 5 

18. String manipulations are defined in ____ header file. 

 a) string.h b) String c) st.h d) std.h 

19. ____ function returns the number of characters stored in the array. 

 a) strlen() b) str() c) stlen() d) strlength() 

20. ___ functions copies source string to target string. 

 a) strcpy() b) str() c) scpy() d) stcp() 

21. _____ function compares the two given strings. 

 a) strcpy() b) strlen() c) stcrsmp()  d) strcmp() 

22. ___ dimensional array is an array in which each elements it itself an array. 

 a) 2 b) 3 c) 4 d) 1 

23. The number of elements in a 2-dimentional by multiplying number of ____ with number  

      of _____.  a) rows,columns     b) columns,columns    c) row,row     d) row,coln 

24. The subscript always commences from_____. a) 1 b) 2 c) 4 d) 3 

25. If the elements are stored in row wise manner it is called as ____ order. 

 a) row – major b) column – major  c) row  d) column 

26. When elements are stored column wise manner it is called as _____ order. 

 a) column – major     b) row – major  c) row  d) column 

27. A ___ is a set of mn numbers arranged in the form of a rectangular array of m rows and  
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     n columns.  a) matrix b) Determinant c) array d) row. 

28. The ____ character is very important, as it acts as the string terminator. 

 a) Null b) String c) int  d) float 

29. Matrices can be represented through ___ arrays. 

 a) single b) 2 –D c) 3 – D d) multi - dimensional  

30. Character array should be initialized using ___ quotes. 

 a) Single b) no c) double d) any 

31. An integer array with index from 0 to 4 all having value 1 may be declared and  

      initialized____.  a) int x[4] = {1}   b) int x[4]={1,1,1,1)   c) int x[5]=(1,1,1,1,1)  d)int x[] = {} 

32. The function strcpy(s1,s2)____       a) copied s1 to s2 b) copies s2 to s1 

 c) appends s1 to end of s2  d) appends s2 to end of s1. 

33. Which of the following is a derived data type? 

 a) Union b) float c) Double d) Array 

34. Arrays in C++ belong to which of the following data type?  

 a) Basic  b) Derived c) User defined d) Primitive 

35. In a 2-D array, the first sub-script stands for_______. 

 a) row  b) column c) diagonal    d) object 

 

 

6. Classes and Objects 

 

1. Which of the following is a way to bind the data and its associated functions together? 

 a) Class b) Data c) Functions d) Methods 

2. The most important feature of c++ is the ___. 

 a) Integer b) float c) class d) arrays 

3. In c++ functions are also called ___.a) Definitions  b) concepts c) organisers  d) methods 

4. Declaration and function definitions are two specifications of which of the following__. 

 a) data type  b) Class c) Comments d) none of the given 

5. Which of the following is a user defined data type? 

 a) Class b) Object c) Public d) Protected 

6. The body of the class starts and ends with_______.  

 a) Semi colon b) Begins and end  c) Start and stop d) Braces i.e. { } 
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7. Declaration of class members are declared as private can be accessed only ____. 

 a) Within class    b) outside the class   c) inside or outside the class     

 d) separately in another class 

8. The class body has ___ access specifiers.  a) 1 b) 2 c) 3 d) 4 

9. Class access specifiers are also known as ____.    a) Specifications b) Class depth 

 c) Visibility labels  d) Class visibility specifications 

10. By default class members are treated as ____ . 

 a) Public b) Private c) Protected  d) Unprotected 

11. Which of the following is not a valid class specifiers? 

 a) Public b) Private c) Protected  d) Pointer 

12. The member declared as ___ can only be accessed within the class. 

 a) Private b) Public c) Protected  d) Class 

13. The class members declared___ can be accessed only within the class and the  

      members of the inherited classes.   a) Private   b) Public  c) Protected d) Unprotected 

14. The member functions declared under which scope can be accessed by the objects of  

      that class?  a) Private b) Public c) Protected  d) Global 

15. The binding of data and functions together into a single entity is known as ___. 

 a) Inheritance  b) Polymorphism c) Overloading d) Encapsulation 

16. Data hiding refers to __________. 

 a) Members and functions of a class are not accessible by members of outside class 

 b) Declaring members as public c) Not giving names to data 

 d) Not specifying members and functions of a class 

17. Data abstraction in c++ is achieved by ____. 

 a) Inheritance ()  b) Polymorphism ()  c) Overloading () d) Encapsulation () 

18. OOP stands for ______. a) object oriented process b) object oriented programming 

 c) Online objects programming d) object to objects programming 

19. __ of a class are data variables that represents the features of properties of a class. 

 a) Data members  b) Member functions c) Access specifiers   d) Visibility labels 

20. ___ are the functions that perform specific task in a class. 

 a) Data members   b) Member functions   c) Concrete functions   d) data functions 

21. In a class data members are also called as ___. 

 a) Abstracts  b) properties c) Attributes d) Dimensions 
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22. class student 

  { 

 int x,y; 

 } s1,s2; 

 From the above code s1,s2 are ____.    a) Objects of class students   

 b) Similar classes of students c) super class of students  d) Sub class of students 

23. The members that can also be accessed from outside the class should be declared as 

___.  a) private  b) Public c) protected  d) None of these 

24. The member of a class are accessed ____. a) Only by member functions of its own class     

      b) By any functions    c) Only by friend functions                 

      d) Only by member functions of its own class and friend functions 

25. The class access specifiers used to access friend functions is ______. 

 a) Private b) Public c) protected  d) Both (B) and (C) 

26. The members defined within the class behave like ___ functions. 

 a) Public b) Friend c) Inline d) None of these 

27. void sum:: input()    The above line tells _______. 

 a) Functions sum is declared within the class input 

 b) Function input is declared within class sum 

 c) Function sum is sub function of input. 

 d) Function input is sub function of sum. 

28. Which of the following statements is NOT true? 

 a) Member functions can be of static type. 

 b) The return type of a member function cannot be of object data type. 

 c) A non-member function cannot access the private data of a class. 

  d) Several different classes can use the same function name. 

29. :: is a ________.   a) Short circuit AND  b) short circuit OR 

 c) Not operator  d) Scope resolution operator. 

30. When objects of a class are created separate memory is allocated for? 

 a) Member functions only b) Both member variables and member functions 

 c) Member variables only d) Neither functions nor variables. 

31. One copy of ___ data members of a class are shared by all objects of that class. 

 a) Inline b) Private c) Static d) Public 
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32. ___ member variable are initialized only once when the first object of its class is 

      Created.       a) Static b) Private c) Public d) Inline 

33. The lifetime if a static member variable is some as ______. 

 a) The first object of its class  b) The private of variables of any object 

 c) The public variables of any object   d) Lifetime of the program. 

34. class example 

 { 

 int x,y,z; 

 float m,n; 

 }p[4]; 

 By the above code how many objects of the class example are created? 

 a) 3  b) 4  c) 5  d) 1 

35. Class comprises ________.  a) Data members  b) Members functions 

 c) Both (a) and (b)  d) None of these 

36. Private access specifiers is accessible by special function called_____. 

 a) Void b) inline c) Friend d) all of these. 

37. Every class declaration is terminated by __.  a) ,     b) . c) ::      d) ; 

38. A class belongs to which of the following data types? 

 a) user defined type   b) Built-in type     c) Derived type    d) Array type. 

39. A member function calling another function directly is called as___ functions. 

 a) Nesting b) recursive  c) Friend d) Inline 

40. ___ member variable are initialized only once when the first object of its class is created  

 a) Static b) private c) Public d) Inline 

41. By default class members are treated as ________. 

 a) Public b) Private c) Protected  d) Unprotected 

42. In a class data members are also called as _______. 

 a) Abstracts  b) Properties c) Attributes d) Dimensions 

43. Declaration and functions definitions are two specifications of which of the following __. 

 a) Data type  b) Class c) Comments d) None of these 

45. The class members declared ____ can be accessed from outside the class also. 

 a) Private b) Public c) Protected  d) Unprotected. 
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46. The members of a class are accessed using___. 

 a) New operator b) Size of operator  c) Dot operator d) + operator. 

47. The return type of a member function of a class can be________. 

 a) Only a valid C++ data type b) Only object data type  

 c) A valid C++ data type or object data type  d) None of these. 

48. class product 

 { 

 int code,quantity; 

 float price; 

 pubic: 

  void asign_data(); 

  void display(); 

 }; 

 void main() 

 { 

  Product p1,p2; 

 } 

 Answer the following table. 

Object Data members Memory alloted 

S1   

S2   

 

  

7. Polymorphism 

 

1. The polymorphism means ______. 

 a) Single form b) Many shapes c) two forms  d) Many programs 

2. Polymorphism is achieved through ________. 

 a) Heritance     b) Encapsulation c) Over loading d) Poly programming 

3. The ability of a function to process the message or data in more than one form is called  

    as ______. a) Function overloading b) Function type c) Recursive function 

 d) Inline function 
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4. Each overloaded function must differ____.  a) By the member of arguments 

 b) By type of arguments    c) Either by number of arguments or by data types of  

arguments.  d) None of these 

 5. The mechanism of giving special meaning to an operator is called ____. 

 a) Operator overloading b) Function overloading c) inheritance d) Object 

 6. While invoking functions if the C++ compiler does not find the exact match of the  

    function call statement then______. a) it will ignore the function call 

 b) generates an error    c) Deletes the function   d) looks for the next nearest match 

7. During integral promotion, a char data type can be converted to ___ 

 a) integer b) Float c) Double d) All the above 

8. The return type of overloaded functions _______- 

 a) Must be same    b) Must be different    c) May or may not be same  d) None of these 

9. The functionality of operator like ‘+’ can be extended using_______ 

 a) Operator precedence   b) Operator overloading   c) operator definition  d) none 

10. which of the following operators cannot be overloaded? a) + b) ++ c) -- d) :: 

11. Operator overloading ______.  a) does not overrule definition of the operator 

 b) Overrules original definition  c) Changes original definition    d) none 

12. The operator function must be _______. a) Member function 

 b) a friend function b) Either member or friend function   d)None of these 

13. When overloaded operators, the overloaded operator must have______ 

      a) All the operands of user defined type     b) At least one operand of user defined type 

      c) All the operands of C++ Data type        d) None of the given 

14. A function have more than one distinct meaning is called ______ function. 

 a) Polymorphism b) Overloaded c) Prototype  d) Parameter 

15. ____ promotions are purely compiler oriented. 

 a) Character b) Floating point c) integral d) Constant 

16. The ____ operator must have at least one operand of user defined type. 

 a) Existing b) Binary c) New d) Overloaded 

17. Binary operators overloaded through a member function take one ___ arguments 

 a) Implicit b) Explicit c) Complete  d) Default 

18. The ____ function definitions are permitted for used defined data type. 

 a) friend b) Size of c) Overloaded d) Basic 
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19. In function overloaded do not use the __ function name for two unrelated function. 

 a) Same b) Different   c) Similar d) Complement 

20. When overloading operators, only ___ operators can be overloaded new operators  

       cannot be created.  a) Binary   b) Relevant c) Existing d) Similar 

21. Which of the following is not a valid function prototype? 

 a) void fun(int x);   b) void fun(int x,int y);    c) int fun(int x)      d) void fun(char x)        

            void fun(int y);       void fun(int x,float y)      void fun(float x)      void fun(char x,int y) 

22. The mechanism of giving special meaning to an operator is called as __ overloading 

 a) data b) Function  c) variable c) Operator 

 

Read the program and answer the following questions 

 

 # include <iostream.h> 

# include <conio.h> 

class negative 

{ 

   int i; 

   public : 

   void accept() 

   { 

   cout << “\nEnter a number ...”; 

  cin >> i; 

   } 

   void display() 

   { 

  cout << “\nNumber ...”<<i; 

   } 

  void operator-() 

   { 

   i = -i; 

   } 

  }; 

void main() 
 { 
 clrscr(); 
negative n1,n2; 
n2.accept(); 
-n2; 
n2.display(); 
getch();  
} 
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 23. The prototype of the overloaded member function is ____   a) negative operator-()       

      b) void operator minus    c) void operator –()    d) Void operator – (negative) 

24. Which of the following statements invokes the overloaded member function? 

 a) Negative n1() b) --n2 c) n2+ d) –n2. 

25. Identify the operator that is overloaded.  a) =    b) – (unary)  c) – (Binary)  d) negative. 

 

8. Constructors and Destructors 

 

1. When an instance of a class comes into scope, the function that executed is ____. 

 a) Destructors b) Constructors c) Inline d) Friend 

2. When a class object goes out of scope, the functions that gets executed is ____. 

 a) Destructors b) Constructors c) Inline d) Friend 

3. The name of constructor must be ____.   a) same as one of the member function 

 b) same as class name c) same as object name d) None of these 

4. Which of the following is false? a) Constructor and destructor have same one 

 b) Class and constructor have same name   c) Class and destructor have same name. 

 d) Constructor and member function have same name 

5.  Which of the following do not return any value?  a) member function     

  b) Inline function    c) Friend function   d) Constructor & destructor 

6. Which of the following is automatically executed when an object is created? 

 a) member function   b) Inline function    c) Friend function   d) Constructor & destructor 

7. Which one of the following initializes a class object and allocates memory space? 

 a) a) Destructors b) Constructors c) Inline d) Friend 

8. Which of the following is not true?  a) Constructor cannot be overloaded 

 b) Constructor is executed automatically    c) Constructor can have parameter 

 d) Destructor cannot be overloaded 

9. Which is executed automatically when the control reaches the end of the class scope? 

 a) Constructor b) Destructor c) Overloading d) Copy constructor 

10. Which of the following prototype can be a copy constructor of class myclass?  

 a) myclass(int myclass)     b) int copy (myclass mc)     

 c) myclass copy (myclass a)  d) myclass(myclass &x) 
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11. A copy constructor is invoked when ____  a) a member function returns an object  

 b) an object is passed as a parameter to any of the member function 

 c) an object is passed by reference to constructor  d) all the above. 

12. Which of the following is not true? 

 a) an object is passed as a parameter to any of the member function 

 b) a member function returns as object  

 c) an object is passed by reference to constructor     d) all the above 

13. Which of the following is true?     a) A constructor can have parameter list       

b) The constructor is executed automatically  

    c) The constructor function can be overloaded d) all the above 

14. Which of the following is a function that removes the allocated memory of an object? 

 a) Constructor b) Destructor c) Member function d) Copy constructor 

15. A Destructor name must be ____.  a) same as one of the member function 

 b) same as class name prefixed by tilde(~)character c) same as object name  

 d) None of these 

16. Which of the following cannot have arguments? 

 a) Constructor b) Destructor    c) Function overloading     d) operator overloading 

17. How many constructor a class can have? a)1 b) 4 c) 6 d) Many 

18. How many Destructor a class can have? a)1 b) 4 c) 6 d) Many 

19. Constructor should be declared under the scope___. 

 a) Private b) Protected  c) pointer d) Public. 

20.When an object is passed by reference  to constructor that is executed is ___. 

 a) Copy b) Static c) Default d) Inline 

21. The constructor defined by the computers in the absence of user defined constructor  

      is ___.  a) Copy b) Static c) Default d) inline 

22. The special character related to destructor is ___. a) + b) ? c) ~ d) ! 

23. The constructors defined by the computers in the absence of user defined constructor 

 Is called as ____. a) Non-parameterized   b) default  c) compiler generated  d) all of 

24. The constructor without any parameter is called as ____. a) Initial constructor     

      b) instance constructor c) default constructor     d) parameterized constructor 
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Read the following program and answer the following answer 
 

#include<iostream.h> 

#include<conio.h> 

Class simple 

{ 

float  x; 

public: 

simple() 

{ 

x=1.0; 

} 

Simple(float m) 

{ 

x=m; 

} 

Simple(float a,float b) 

{ 

x=a+b; 

} 

Simple(simple &k) 

{ 

x = k*x; 

cout<<”\n copy constructor invoked \n”; 

} 

Void show() 

{ 

cout<<”\n x=” <<x<<’\n’; 

} 

}; 

25. Write prototype of non-parameterized constructor___. 

26. Write prototype of parameterized constructor____. 

Void main( ) 

{ 

Clrscr ( ); 

Simple s,s1; 

S1.show( ); 

Simple s2 (7) , s3 (s1); 

Simple s4 = s2,s5(4,5); 

s = s5; 

s2.show ( ); 

s3.show( ); 

s4.show( ); 

s5.show( ); 

s.show( ); 

getch( ); 

} 
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27. Write prototype of copy constructor ____. 

28. Name the private members of the class ____. 

29. Identify statements that invoke copy constructor _____.   

 

Read the following program and answer the following answer 
 

#include<iostream.h> 

#include<conio.h> 

Class example 

{ 

Int x,y; 

Public: 

example (example &a) 

{ 

x = a.x; 

y = a.y; 

cout<<”copy constructor….”; 

} 

example( ) 

{ 

x = 1; 

y = 1; 

} 

example(int a,int b) 

{ 

x = a; 

y = b; 

} 

Void display( ) 

{ 

cout<<”\nx=”<<x<<”and y”<<y; 

} 

}; 

void main( ) 

{ 

Clrscr( ) ; 

example e1; 

example e2(2,4); 

example e3 = e2; 

e1.display( ); 

e2.display( ); 

e3.display( ); 

getch( ); 

} 
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30. Write prototype of non parameterized constructor____. 

31. Write prototype of parameterized constructor____. 

32. Write prototype of copy constructor____. 

33. Name private members of the class ____. 

34. Name Public members of the class ____. 

35. Identify statements that invoke copy constructor ____. 

 

9. Inheritance 

 

1. The process of creating new data types from existing data type is called…… 

 a) Inheritance b) Polymorphism c) Overloading d) Encapsulation 

2. The class created from an existing base class is called ….. 

 a) Second class b) New class c) Rich class d) Derived class 

3. In Inheritance, the newly created classes are ….. 

 a) Base class b) Derived class c) Super class d) function 

4. In real life, children acquire the futures of their parents in adition to their own unique          

   features. Which of the following terms refers this? 

 a) Encapsulation b) polymorphism c) overloading d) inheritance 

5. Reusability of code, code sharing, consistency of interface are all advantages of…… 

 a) inheritance b) polymorphism c) overloading d) Encapsulation 

6. Which is the following is true? 

 a) Base class inheritance properties from derived class 

 b) Derived class class inheritance properties from base class 

 c) Derived class does not inherit any properties from base class 

 d) both a and b are true 

7. Which of the following derives a new class “sub_class” from the base class “main_class”? 

 a) class main_class: public sub_class b) class sub_class; public main_class 

 c) class main_class: class sub_class  d) class sub_class: public main_class 
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8. What is wrong with the following statement that derives a B_class from A_class?  

    Class B_class; public A_class 

a) Semicolon (;) must be replaced by colon (;) 

b) Semicolon (;) must be appear at end of the statement 

c) The world public must be replaced by private 

d) The world public must be replaced by protected 

9. Class xclass: public yclass   from the above statement which of the following is true? 

 a) xclass is the base class  b) yclass is the base class 

 c) yclass is derived from xclass d) yclass is the derived class 

10. Private, public and protected are all ………. 

 a) C++ variables   b) Control structures of C++  

c) Access Specifiers  d) Derived class members 

11. The default visibility mode while inheriting members of a base class is……. 

 a) private b) protected  c) public d) extended public 

12. Which of the following is true with respect to inheritance? 

 a) Private members of base class are inherited to drived class with private                    

     accessibility 

 b) Private members of base class are not inherited to drived class with private                   

     accessibility 

 c) Public members of base class are inherited but not visible to derived class  

 d) none of the given 

13. In inheritance, protected members of base class are inherited as….. when private access  

      specifier is used 

 a) private members   b) protected members   c) public members    d) not inherited at all 

14. When a class is derived by private access specifier, the bublic members of base class are  

      inhirited as  …………  of derived class 

 a) private members b) protected members   c) public members    d) none 

15. When a class is derived by protected access specifier, the public and protected members  

      of  base class are inherited as ……… of drived class 

 a) private members   b) public members c) protected members d) none 
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16. When a class derived by access specifier protected, the public members of base class are  

       inherited as …….. of derived class 

 a) private members b) protected members   c) public members    d) none 

17. When a class derived by access specifier public, the protected members of base class are  

       inherited as …….. of derived class 

 a) private members b) protected members   c) public members    d) none 

18. When a class is inherited by public visibility mode the public members of base class are  

      derived as ………. Derived class 

 a) private members b) protected members   c) public members    d) none 

19. Single, multiple, multilevel, hybrid and hierarchical are all types of….. 

 a) Polymorphism b) Inheritance c) Encapsulation d) overloading 

20. When a sub class inherits only from one base class it is known as…… 

 a) single inheritance b) double inheritance c) hierarchical inheritance  d) none 

21. The symbol that must be used between derived and base class is……. 

 a) &  b) :  c)  ::  d) #   

22.  A derived class that inherits from multiple base class is known as…….. 

 a) single inheritance   b) multiple inheritance  

c) multilevel inheritance   d) hybrid inheritance 

23.Classes used for only deriving other classes are called….. 

 a) public classes b) abstract class c) derived class d) objects 

24. The class from which the other classes are derived is called…. 

 a) objects b) object class c) sub-class  d) function 

25. Which is not inherited from base class? 

 a) object b) function c) constructor d) data member 
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Read the following program and answer the following answer 
 

class vehicle 

{ 

int wheels; 

public: 

void inputdata( int, int); 

void outputdata(); 

protected : 

int passenger; 

}; 

class heavy_vehicle : protected vehicle 

{ 

int diesel_petrol; 

protected: 

int load; 

26. Which is the base class of the class heavy_vehicle? 

 a) bus b) heavy_vehicle c) vehicle d) both a and c 

27. The data member that can be accessed from the function display data () is …… 

 a) passenger b) load c) marks d) all of these 

28. The data member that can be accessed by an object of bus class is…… 

 a) input data    b) read data 

     output data            write data 

 c) fetchdata     d) all of these 

    display data 

29. Name the derived class of the class  heavy_vehicle________ 

30.  Name the data members that can be accessed from the function displaydata() _________ 

31.  Is the member function output data accessible to the objects of heavy_vehicle class _______. 

 

 

 

 

Public: 

void readdata( int, int); 

void writedata(); 

}; 

class bus: private 

_heavy_vehicle 

{ 

}; 

char marks[20]; 

public: 

void fetchdata( char ); 

void displaydata(); 
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Read the following program and answer the following answer 

 

#include<iostream.h> 

#include<conio.h> 

Class inherit 

{ 

Private: 

 Int x,y; 

Public: 

 Inherit() 

 { 

 x =1;y=2; 

 { 

 Void print( ) 

 { 

 Cout<<”y=”<<y<<end1; 

 } 

  }; 

 

32. What are the private data members of class inherit? 

33. What are the public members of class inherit? 

34. What are the members inherited by the class inherit1? 

 

10. IMPACT OF COMPUTERS ON SOCIETY 

 

1. The technical elements we need to reach out the benefits if IT to the common man are _. 

 a) Connectivity b) Affordable computers  c) Software  d) All of these 

2. 85% of computer usage is ___. a) Word processing   b) Graphics   c) Animation   d) None. 

3. Which of the has changed our life style? a) Browsing   b) e-mail    c) chat     d) All of these 

4. Which of the following enables data storage and management? 

 a) LCD screen b) Picture phone c) Archinve unit d) Speakers 

 

Class inherit1: public inherit 

{ 

}; 

Void main( ) 

{ 

Clrscr( ); 

Inherit i; 

Inherit1 a; 

i.print( ); 

i.print( ); 

getch ( ); 

} 
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5. The purpose of personal archives is ____. 

 a) LCD screen b) picture phone c) Archive unit d) Speakers 

6. In a computerized homes,Which of the following rooms have LCD screen,archive  

    unit,personal archives,emotional containers etc? 

(a)living room         (b) kids room       (c) home office        (d) bed room 

7. Whichprevents people from acquiring bad habits? 

    (a) archive unit            (b)emotion containers      (c) camera            (d) speakers 

8…………..  are mounted on the wall to provide better effect and save floor space. 

     (a)LCD SCREEN        (B)camera          (c)speakers                (d) all the given 

9………..is a picture based personal telephone directory.      (a) picture phone and pad              

     (b) personal archives    (c)emotional container               (d)archive unit 

10…………. Features allows to sing alone with audio coming from orginal source. 

     (a)kara-oke            (b)memo frame      (c)projection TV           (d)interactive table cloth 

11…………… can function as electronic pets. 

     (a) archive units          (b)memo pads   (c)ceramic audio            (d)robots 

12.kara-oke,electronic pets,games over net are all part of which of the following rooms in  

      a coputerised home…………. 

       (a)LIVING ROOM      (B) KIDS ROOM        (C)HOME OFFICE           D) dinnig room 

13.animated stories package,memo frame,Bookshelf,personal creativity tool are all              

     located in which of the following places of a computerized home…. 

a) kids room          b)Bed room        c)home office       d) dinning room 

14…………. Means easy interaction with other people through touch screen,scanner and  

     microphone facilities. 

        a) memo frame         b)bookshelf         c)Archive units         d) kara-oke 

15. In a computeraised home,………….has touch and  voice control for various  

     appliances,projection TV,Alaram clock,moving telephone ete. 

     a) kids room            b) bed room         c) home office       d)dinning room 

16. in which of the following rooms mirrors,medical box and special speakers are located  

     of a computerized home?........ 

       a)kitchen         b)bed room      c)bath room              d)kids room 
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17. speakers,intelligent aprons,food analyzer,health monitor are found in……..of a  

     computerized home. 

      a)kitchen      b)bed room          c)bath room                d)kids room 

18. interactive table cloth keeps the food……………… 

        a)hot                  b)cool         c)sufficiently warm                          d)packed 

19. interactive table cloth and ceramic audio player are found in ……….. of a  

      computerized home………….. 

      a)kitchen            b)bed room       c)bath room    d)dinning room 

20……………..enable us to withdraw money from our accounts in a particular bank  

     anytime and any where. 

     a)ATM                b)archives     c)picture phone and pad                   d)memo frame 

21…….permits banking from the comfort of the home by using internet facilities.  

      a)ATM          b)e-Banking       c)memo frame          d)none of the given 

22. through……..we can purchase any prodect,any brand,any quality from any where. 

      a)ATM               b)e-banking         c)e-shoping          d)e-governance 

23. CBT stands for…..     a)computer based tutorials      b)computer based teaching 

      c)common basic techniques               d)control bullet in table 

24. ATMis example for…….. 

      a)e-shoping      b)  e-banking       c)transcription     d)digitization 

25………….enable online educational programs leading to degrees and certifications. 

     a)e-shopping      b)e-banking           c) e-commerce         d)e-learning 

26 ……….facilitates remote diagnostics. 

      a) ATM       b) e-learning        c) internet        d)none of given 

 

11. IT ENABLED SERVICES 

 

1. ITES means ________.  a) Improving technology enlighting services    

 b) Inforamtion techonology enabled  services 

 c) Information techonology extended services d) Information entrusted systems 

2. Which of the following is an IT enabled service? 

 a) E-Governence b) Word processer  c) Spreadsheet d) database 
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3. Which of the following is not an IT enabled service? 

 a) Callcentres b) E-Govenence c) Data digitization d) Word processer 

4. A facility that allows the user to speak into a special device while typing a letter using 

   Computer is called ________.a) Cell phone    b) Telephone     c) Dictaphone   d) Speaker 

5. Which of the following is sometimes defined as a telephone base shared services? 

 a) Data digitization     b) Call centre    c) Data management    d) Bar code recongnition 

6. Collection digitization and processing of data is basic function of __________. 

 a) Call centre b) Data management       c) E-Governance     d) Data collection 

7. Which of the following is not an ITES of data manadement category?  a) Data entry     

  b) Custom reports c) Character regonition and processing d) Transcription 

8.  Which of the organization can potentially benefit from ITES? 

 a) Banking  b) Insurance c) Legal d) All the above 

9. ___ is a permanent legal document that formally states the result of a medical  

   investigation. a) Medical transcription  b) Medical prescription 

 c) Medical document  d) Medical anatomy 

10. ____ refers to conversion of non – digital material to digital form. 

 a) Transcription b) Data transfer c) Data digitization d) Noen of the given 

11. Long term preservation storage of important documents easy to use and access of  

      information are all benefits of _________. a) Medical transcription    b) Call centre 

 c) data digitization d) Web based services 

12. Career guidance employment online examnation results online are all ______. 

 a) Web based service b) Data processing service c) Call centre service 

 d) Transcription   

13. BPO may be expanded as ______ a) business product outcome b) Business process  

      outcome c) Business product outsourcing d) business process outsourcing 

 

 

12. COMPUTER ETHICS 

 

1. Computer ethics has its  riits in the work of ____ during world war II. 

 a) Charles babbage    b) Blaise bascal     c) Norbert wiener     d) Herman horllerith 
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2. Who amoung the following began to examine unethical and illegal uses of computers 

    By computer professionala in mid 1960s in Menlo park, California?_____. 

 a) Charles babbage    b) Blaise bascal     c) Norbert wiener     d) Herman horllerith 

3. ____ is a set of rules for determining moral standards or socially acceptable bahaviour 

    a) Standard b) Ethics c) protocol  d) None of the given 

4. General guidelines of computer ethics are needed for ___. 

 a) Protection of personal data   b) Computer crime    c) Cracking d) All the above 

5. The protection of hardware facilities magnetic disks and other illegal accessed stolen 

     Damaged or destroyed items refers to _____ security. 

 a) Physical  b) Personal  c) personnel  d) none of the given 

6. ____ security  refers to software setups that permit only anthorzied access to the system 

 a) Physical  b) Personal  c) personnel  d) none of the given 

7. ___ security refers to protecting data and computer system against dishonesty or  

    Negligence of employess. a) Physical    b) Personal    c) personnel    d) none of the given 

8. “Cracking” comes under ____. 

 a) Data security b) Computer crime c) Website service  d) Transcription 

9. Making and using duplicate hardware and software is called ____. 

 a) Copy right b) Free copy  c) piracy d) none of the given 

10. ___ is a self-replicating program that can cause damage to data and files stored on 

     Your computer.  a) Piracy b) Freeware  c) Virus d) none of the given 

11. Running other software for the idel computer without the knowlwdge of the organization 

     Is called theft of _______. a) Computer crime   b) Use    c) Computer    d) software 

12. ___ is the illegal access to the network or computer system. 

 a) Piracy b) Virus c) Cracking d) Security 

13. Which of the following is not a way of protection?  a) Physical Security  

 b) Personal Security  c) personnel  Security d) Piracy 
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Volume - I 

1. An introduction to staroffice writter 

2 marks 

 1. What is text editing? 

 2. What is word processer? 

 3. How would you switch over from insert mode to type over mode? 

 4. How would you select the required portion of the text in a document?(using keyboard) 

 5. How would you select the required portion of the text in a document?(using mouse) 

 6. What is Insertion point? 

 7. How will you create a new document? 

5 marks 

 1. What are the steps to be followed for search and replace a given word? 

 2. How would you select the required portion of the text in a document? 

 

2. Text formatting 

2 marks 

 1. What is the difference between hard formatting and soft formatting? 

  A Hard return is inserted every time when Enter key is pressed. Soft returns are  

      Inserted as line breaks by star office writer and are adjusted when text is added 

     or deleted. 

 2. What is text formatting? 

 3. What is indenting text? 

 4. What is text highlighting? 

 5. What is alignment? Write the types. 

 6. What is style? 

 7. What is hanging indent? 

 8. What are the steps to be followed to change the line spacing? 

5 marks 

 1. How can we indent text with the paragraph dialog box? 

 2. How can we apply different styles for bullets and numbers? 
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3. Correcting Spelling mistakes. 

2 Marks 

 1. What dios automatic spelling correcting mean? 

 2. How can we correct mistakes? 

 3. What is auto correct option? 

5 marks 

 1. How would you carry out the spelling check after the entire document is typed? 

 2. how would you add a word in the autocorrect list of the staroffice? 

 

4. Working with tables 

2 Marks 

 1. How will you create table in a document? 

 2. How will you add a required number of rows and columns in a table? 

 3. How to change the width of a column in a table? 

 4. How to make the selected rows and columns of the same size? 

 5. How will you delete entire table? 

 6. How to change the height of a row in a table? 

5 marks 

 1. What are the various function of the icons in the table formatting toolbar? 

 

5. Page formatting 

2 marks 

 1. What is page formatting mean? 

 2. What is page orientation? Write and explain the types 

 3. What is meant by header and footer? 

 4. How will you insert page numbers in footer? 

5 marks 

 1. Explain the process of changing margin. 

 2. How will you insert header and footer in entire document. 
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6. Spread sheet 

2 marks 

 1. What is an electronic spreadsheet? 

 2. Can we change the data present in a cell? If so,how? 

  Yes. We can change the data present in a cell.  

     i. Type in the new data. The new data will simply overwrite the old contents of the cell.  

    ii. Click on the formula bar with the mouse. Press the F2 function key or simply double 

       click on the cell. A vertival cursor appears on the formula bar. Move the cursor to the  

               left arrow key or the backspace key and edit the data. 

 3. What is function? Write the example 

 4. What is date arithmetic? 

 5. What is cell pointer? 

 6. How will you change the width of a column in a worksheet? 

 7. What is cell referencing? Write and explain the types. 

 8. What is the use of autoformat sheet? 

 9. What are the advantages of using electronic spreadsheet? 

5 marks 

 1. What are the various facilities for drawing available in staroffice calc? how can they  

              be used? 

 2. What are the formatting options available in starcalc? 

 3. How will you insert cell,row and column in a worksheet? 

 4. Explain the procedure to be followed to draw a chart. 

 5. How can you generate a series of valus? Explain with an example. 

 6. What is function? Explain with sutable example. 

 7. What are the various icons in the insert object floating toolbar? 

 

7. Database 

2 marks 

 1. What is data processing? 

 2. What is database? 

 3. What does it means to filter database records? 

 4. What is Primary key? 
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 5. What is meant by filter? Write the types 

 6. How will you sorted the records? 

 7. What is multiple sorting? 

5 marks 

 1. What is Database? Expalin the types. 

 2. How can s database be queried? How can we create query in database? 

 3. How will we manipulate the database? Explain. 

 4. Explain report generation. 

 5. Explain Form designing. 

 

8. Introduction to multimedia 

2 marks 

 1. What is multimedia? 

 2. What MMS? 

 3. Write a note on how to create a 3-D animation. 

 4. What are the uses of morphing and warping? 

 5. What is compression? Explain the types. 

 6. Define MIDI. 

 7. What is MP3/MPEG format? 

 8. Explain multimedia formats. 

 9. What is inline sounds and video. 

 10. What is digital sampling? 

9. Presentation. 

2 marks 

 1. what is presentation? 

 2. How to create new presentation? 

 3. What is custom animation? 

 4. What is slide transition? 

 5. Explain various types of views? 

 6. Write short notes: Master page,layout. 

 7. How will you rename a slide? 

 8. How to start a presentation? 
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 9. What is meant by rehearse timings? 

 10. How will we change the background of a presentation? 

 11. Explain the media playback toolbar. 

 

Volume II 

1. Object oriented concepts using C++ 

2 Marks 

1. What is the significance of an object? 

2.  What is encapsulation? 

3. How is polymorphism diffenent from inheritance? 

 Polymorphism promotes, reduces software complexity, as multiple definitions are 

   Permitted to an operator or function. Inheritance allows a class to be derived from an  

   Existing class thus promoting reusability of code. 

4. What is class? 

5. What is inheritance? 

2. Overview of C++ 

2 marks 

  1. What are tokens? Write the types 

 2. What are constants? 

 3. What is string literal? Give example. 

 4. How are the operators classified? 

 5. What are relational operators? 

 6. What are conditional operators? Give its syntax. 

 7. Explain Type definition and enumeration. 

 8. What is the use of void type? 

 9. What is a pointer an address? 

 10. What is the impact of modifiers? 

 11. Write syntax of Type definition and enumeration 

12. What is storage class? Write the types. 

13. Explain storage classes. 

14. What are the rules for implicit conversion? 

15. What is the of the operators related to pointer variable? 
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3. Basic statement 

2 marks 

1. What are the different statements in C++? 

 2. What is assignment operator? Which operator is used for assignment operator? 

 3. What is control statement? 

 4. What is continue statement? 

 5. What is difference between continue and break statement. 

 6. Write the syntax of simple if, if-else statement and switch case. 

 7. Write the syntax of for,while and do-while loop. 

 8. Write the rules of nested loop. 

5 marks 

 1. What is simple if and if-else statement? Give an example. 

 2. Explain the switch statement with suitable example. 

 3. Explain the for loop with suitable example. 

 4. Explain the while loop with suitable example. 

 5. Explain the do-while loop with suitable example. 

 

4. Function 

2 Marks 

1. What are function? 

 2. What are the advantageous of functions? 

 3. What is the main purpose of using function prototype? 

 4. What is inline function? 

 5. Write the rules for actual parameters in function prototype with suitable example. 

5 marks 

 1. Expalin call by value method in function with suitable example. 

 2. Expalin call by reference method in function with suitable example. 

 3. Explain inline function. 

 4. Explain various types of scopes. 
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5. Structured data types – Arrays 

2 marks 

1. What is array? Write the different types. 

 2. Write the syntax of single dimensional array. Give an example. 

 3. What is array of strings? Give an example. 

 4. What is sorting? 

 5. Write the short notes : Strlen(),Strcpy() and Strcmp() 

 

6. Classes and objects 

2 marks 

 1. What is a class? 

 2. What are the two parts of a class specifiers? 

 3. What is encapsulation? 

 4. What is meant by data hiding? 

 5. What is data abstraction? 

 6. Give some valid points about static data members of a class. 

5 marks 

 1. Give tha general form of a class and explain with an example 

 

7. Polymorphism 

2 marks 

 1. What is function overloading? 

 2. How are functions invoked in function overloading? 

 3. Write the rules of function overloading 

 4. What is operator overloading 

 5. List out operators can not be overloaded. 

5 marks  

 1. What is function overloading? Explain with suitable example. 

 2. What is operator overloading? Explain with suitable example  

 3. Write the rules of operator overloading 
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8. Constructors and destructors 

2 marks 

 1. What is constructor? 

 2. What are the functions of constructors? 

 3. What is copy constructor?  

 4. What is destructor? 

5 marks 

 1. write the rules of constructor and destructor. 

 

9. Inheritance 

2 marks 

 1. What is inheritance? 

 2. What are the advantages of inheritance? 

 3. What are the points to be observed while defining a derived class. 

 4. What are the different types of inheritance? 

 5. What is an abstract class? 

5 marks 

 1. Tabulate the scope and accessibility of the base members in the derived class 

             When inherited with different access specifiers? 

 2. Explain the types of inheritance. 

 

10. Impact of computers on society 

2 marks 

1. What is an archive unit? 

2. What are the three technical elements we need to reach out benefits of IT to the 

              Common man? 

 3. What is ATM? 

 4. Write s brief note on e-shopping. 

 5. Write is meant by e-learning. 

 6. Name areas of healthcare in which computers are used? 

 7. Explain how computer help in agriculture 
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11. IT Enabled services 

2 marks 

1. What is an ITES? 

 2. What is Dictaphone? 

 3. What is e-governance? 

 4. What is the use of call centers? 

 5. What is data management? 

 6. What is data digitization? 

12. Computer Ethics 

2 marks 

 1. What is the need for a password to log into a computer system? 

 2. How does the operating system enhance the security? 

 3. What does book of norbert wiener contain about computer ethics? 

 4. What are ethics? 

 5. What does physical,personal and personnel security? 

 6. List out some of the common computer crimes. 

 7. What is piracy? 

 8. What is a computer virus? 

 9. What is cracking? 

 10. What is Cyber law? 

 
Find the Errors 

1.  
#include<iostream.h> 
class simple 
{ 
int num1, num2 , sum = 0; 
protected: 
accept() 
{ 
cin>>num1>>num2; 
} 
public: 
 
Answer :  
 

} display() 
{ 
sum = num1 + num2; 
}; 
void main() 
{simple s; 
s.num1=s.num2= 0; 
s.accept(); 
display(); 
} 
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  1. The member sum cannot be initialized at the time of declaration 
  2. The member variable num1 and num 2 cannot be accessed from main() as they are  
      Private. 
  3. s.accept( ) is invalid. The method accept ( ) is defined under protected. 
  4. Display( ) should be invoked through an object. 
 
2. 

Class simple 
{ 
  private : 
   int x; 
  simple() 
 { x = 5; } 
};  

 
3. 
 
 Class simple 

{ 
  private : 
   int x; 
 public : 
simple(int y) 
 { x = y; } 
}; 
void main() 
{ 
  simple s; 
} 

   
 
4.  

#include<iostream.h> 
class A 
{ 
private : 
int a1; 
public: 
int a2; 
protected: 
int a3; 
}; 
class B : public A 
public: 
 
Answer :  
  
1. ‘a1’ is a private members and ‘a3’ is protected member. They are declared in class  

Answer : 
  Public scope is not defined 

Answer :  
  Instance of class simple & is with value 

void func() 
{ 
int b1, b2 , b3; 
b1 = a1; 
b2 = a2; 
b3 = a3; 
} 
}; 
void main() 
{ 
B der; 
der.a3 = 0’; 
der.func(); 
  } 

 

www.kalvisolai.com



Palanigounder Higher Secondary School 
 

- 65 - 

     A.They cannot be accessed. 
 

5.   
#include<iostream.h> 
class A 
{ 
private  
int a; 
public: 
int a2; 
}; 
class B :: public A 
public: 

 

 
 
Answer: 
 

Line no Error line Correct line 
2 class A Class a 
4 private Private: 
9 class B :: public A class b : public a 
10  { is come 
14 getdata(); Not come 
20 void main[] void main( ) 
24  } is come 

‘a1’ is a private members and ‘a3’ is protected member. They are declared in class  
 A.They cannot be accessed. 

 
6.   

#include<iostream.h> 
#include<conio.h> 
class simple 
{ 
private: 
int a,b 
public 
simple() 
{ 
a= 0 ; 
b= 0; 
cout<< “\n Constructor of class-simple “; 
} 
simple() 
 { 
cout<<“\n Destructor of class – simple .. “; 
 } 

void func() 
{ 
int b1, b2 , b3; 
getdata(); 
b1 = a1; 
b2 = a2; 
b3 = a3; 
} 
}; 
void main[] 
{ 
B der; 
der.a3 ; 
der.func(); 
  } 
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void getdata() 
{ 
cout<<“\n Enter values for a and b... “; 
cin>>a>>b; 
} 
    void putdata() 
    { 
   cout<<“\nThe two integers .. “<<a<<‘\t’ b; 
   cout<<“\n The sum of the variables .. “<< a+b; 
    } 
}; 
void main() 
{ 
simple s; 
s.getdata(); 
s.putdata() 
} 

 
Answer : 
 

Line no Error line Correct line 
5 int a,b int a,b; 
6 public Public: 
13 simple() ~simple() 
24 <<a<<‘\t’ b <<a<<‘\t’<< b 
32 s.putdata() s.putdata(); 

 

 
 

Find the output 
 

1.  
#include <iostream.h> 
#include <conio.h> 
# include <iomanip.h> 
void swap (int n1, int n2) 
{   int temp; 
    temp = n1; 

     n1 = n2; 
     n2 = temp; 

    cout << “\n”<<n1<<”\t”<<n2<<”\n”; 
} 
void main ( ) 
{ 
   int m1 = 10, m2 = 20; 
   clrscr ( ); 

    cout <<”\n Values before invoking swap”  << m1 << “\t” << m2; 
             cout << “\n Calling swap..”; 
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              swap (m1, m2); 
  cout << “\n Back to main.. Values are” << m1 << ‘\t’ << m2; 

   getch ( ); 
} 
 
Output : 
 
Values before invoking swap10 20 
Calling swap :20 10 
Back to main…… Values are 10 20 

 
2.  
 

#include <iostream.h> 
#include <conio.h> 
# include <iomanip.h> 
void swap (int &n1, int &n2) 
{   int temp; 
    temp = n1; 

     n1 = n2; 
     n2 = temp; 

  cout << “\n”<<n1<<”\t”<<n2<<”\n”; 
} 
void main ( ) 
{ 
   int m1 = 10, m2 = 20; 
   clrscr ( ); 

    cout <<”\n Values before invoking swap”  << m1 << “\t” << m2; 
             cout << “\n Calling swap..”; 
              swap (m1, m2); 

  cout << “\n Back to main.. Values are” << m1 << ‘\t’ << m2; 
   getch ( ); 

} 
 
Output :  
  

Values before invoking swap10 20 
Calling swap :20 10 
Back to main…… Values are 20 10 

3.  
 # include <iostream.h> 
# include <conio.h> 
float power (float n, int p = 1) 
{ 
  float prd = 1; 
  for (int i = 1;  i<= p; i++) 
prd *= n; 
  return prd; 
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} 
void main ( ) 
{ 

    clrscr ( ); 
    int x = 4, b = 2; 

   cout << “\n Call statement is power(b, x)...” << power (b, x); 
    cout << “\n Call statement is power(b).. “   << power (b); 
    getch ( ); 

} 
 
Output :  
 
Call statement is power (b, x)..16 
Call statement is power (b)..2 
 
4.  
 # include <iostream h> 
# include <conio.h> 
int area (int side1 = 10, int side2=20 
{ return (side1 * side 2); } 
      
Output :  
 
24 
 80 
120 
 
 
 
5.  
#include<iostream.h> 
#include<conio.h> 
class simple_static 
{ 
int a,b,sum; 
static int count; 
public: 
void accept() 
{ 
cout<<“\n Enter values.. “; 
cin>>a>>b; 
sum = a+b; 
count++; 
} 
void display() 
{ 
cout<<“\n The sum of two numbers … “<<sum; 
cout<<“\n This is addition… “<<count; 

void main ( ) 
{    int s1 = 4, s2 = 6; 
clrscr ( ) ; 
     cout << area (s1, s2) << ‘\n’; 
     cout << area (s1) << ‘\n’; 
     cout << area (s2) << ‘\n’; 
     getch ( ); 
} 
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} 
}; 
int static_simple count=0; 
void main() 
{ 
simple_static p1,p2,p3; 
p1.accept(); 
p1.display(); 
p2.accept(); 
p2.display(); 
p3.accept(); 
p3.display(); 
} 
 
Output:  
 
Enter  values      10 20 
The sum of two numbers       30 
This is addition   1 
Enter values……… 5 7 
The sum of two numbers 12 
This is addition 2 
Enter values……….. 9 8 
The sum of two numbers  17 
This is addition 3 
 
 
 
 
6. 
# include <iostream.h> 
# include <conio.h> 
class distance 
{ 
   int feet,inches; 
   public : 
   void distance_assign(int f, int i) 
   { 
 feet = f; 
 inches = i; 
   } 
   void display() 
   { 
cout << “\nFeet   : “ << feet<< “\tInches : “ << inches; 
   } 
   distance operator+(distance d2) 
   { 
 distance d3; 

www.kalvisolai.com



Palanigounder Higher Secondary School 
 

- 70 - 

 d3.feet = feet + d2.feet; 
 d3.inches = (inches + d2.inches) % 12; 
 d3.feet += (inches + d2.inches)/12; 
 return d3; 
   } 
}; 
void main() 
{ 
    clrscr(); 
    distance dist_1,dist_2; 
    dist_1.distance_assign(12,11) 
    dist_2.distance_assign(24,1); 
    distance dist_3 = dist_1 + dist_2; 
    dist_1.display(); 
    dist_2.display(); 
    dist_3.display(); 
    getch(); 
} 
    
Output:  
 
 Feet : 12 Inches : 11 
 Feet : 24 Inches : 1 
 Feet : 37 Inches : 0 
 
 
 
 
 
7.  
#include<iostream.h> 
#include<conio.h> 
class simple 
{ 
private: 
int a,b; 
public: 
simple() 
{ 
a= 0 ; 
b= 0; 
cout<< “\n Constructor of class-simple “; 
} 
~simple() 
 { 
cout<<“\n Destructor of class – simple .. “; 
 } 
void getdata() 
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{ 
cout<<“\n Enter values for a and b... “; 
cin>>a>>b; 
} 
    void putdata() 
    { 
   cout<<“\nThe two integers .. “<<a<<‘\t’<< b; 
   cout<<“\n The sum of the variables .. “<< a+b; 
    } 
}; 
void main() 
{ 
simple s; 
s.getdata(); 
s.putdata(); 
} 
 
Output: 
 
Constructor of class - simple .. 
Enter values for a & b   5 6 
The two integers... 5   6 
The sum of the variables... 11 
Destructor of class - simple  
 
 
 
 
 
 
8.  
# include<iostream.h> 
#include<conio.h> 
class add 
{ 
int num1, num2, sum; 
public: 
add() 
{ 
cout<<”\n Constructor without parameters.. “; 
num1= 0; 
num2= 0; 
sum = 0; 
} 
add ( int s1, int s2 ) 
{ 
cout<<”\n Parameterized constructor... “; 
num1= s1; 

void getdata() 
{ 
cout<<”Enter data ... “; 
cin>>num1>>num2; 
} 
void addition() 
{ 
sum=num1+num2; 
} 
void putdata() 
{ 
cout<<”\n The numbers are..”; 
cout<<num1<<”\t”<<num2; 
cout<<”\n The sum of the    
          numbers are.. “<< sum; 
} 
}; 
void main() 
{ 
add a, b (10, 20) , c(b); 
a.getdata(); 
a.addition(); 
b.addition(); 
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num2=s2; 
sum=NULL; 
} 
add (add &a) 
{ 
cout<<”\n Copy Constructor ... “; 
num1= a.num1; 
num2=a.num2; 
sum = NULL; 
} 
 
Output :  
 
Constructor without parameters.. 
Parameterized Constructor... 
Copy Constructors. 
Enter data .. 5   6 
Object a: 
The numbers are   5    6 
The sum of the numbers are ... 11 
Object b: 
The numbers are   10    20 
The sum of the numbers are . 30 
Object c: 
The numbers are   10   20 
The sum of the numbers are ... 30 
 
 
 
 
9.  
#include<iostream.h> 
#include<conio.h> 
class base 
{ 
public: 
base() 
{ 
cout<<”\nConstructor of base class...”; 
} 
~base() 
{ 
cout<<”\nDestructor of base class.... “; 
} 
}; 
class derived:public base 
{ 
  public : 
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  derived() 
  { 
    cout << “\nConstructor of derived ...”; 
  } 
  ~derived() 
  { 
cout << “\nDestructor of derived ...”; 
  } 
}; 
class derived2:public base 
{ 
  public : 
  derived() 
  { 
    cout << “\nConstructor of derived2 ...”; 
  } 
  ~derived() 
  { 
cout << “\nDestructor of derived2 ...”; 
  } 
}; 
void main() 
{ 
  derived2 x; 
} 
 
 
 
 
10.  
#include<iostream.h> 
#include<conio.h> 
class student 
{ 
int m1, m2, total; 
public: 
student ( int a, int b) 
{ 
m1 = a; 
m2 = b; 
cout<<”\n Non parameterized constructors..”; 
}; 
 
Output:  
 
Non parameterized constructors 

 

Output :  
 
Constructor  of base class 
Constructor of derived. 
Constructor of derived2  
Destructor of derived2 
Destructor of derived 
Destructor of base class .. 
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